2 Replies Latest reply: Feb 3, 2017 4:20 PM by Carmen Reilly RSS

    Qlik Sense Desktop VPN Havoc

    Ted Hartnell

      How do I get Qlik Sense Desktop to work with a VPN?

       

      I have a Windows 10 machine and recently upgraded from Qlik Sense Desktop version 3.1 to version 3.1-SR4. After the upgrade Qlik Sense Desktop stopped working! By that I mean, the Qlik Sense Desktop Hub doesn't load and the Qlik Bubbles don't appear at startup. All that appears is a blank white window. Hitting F5 results in this message appearing:

       

      {"type":"error","severity":"WARNING","message":"The service did not respond or could not process the request"}

       

      The problem is with my VPN. I am in China so a VPN is required to work through the Great Firewall. In the past I would see this same problem if my VPN was OFF - Qlik Sense only worked when the VPN was ON. That was fine with me so I ignored the problem.

       

      But after the upgrade I now have the opposite problem. If I turn the VPN OFF then Qlik Sense suddenly starts to work - the Qlik Bubbles reappear and the Qlik Sense Desktop Hub loads. But with the VPN now OFF all my other apps stop working, so this is not really a viable solution.

       

      In addition, with the VPN now OFF my Sankey extension stops working and I get this message:

       

      Invalid Visualization - The visualization was not found on the server: SenseSankey

       

      I suspect this is a problem related to the Sankey extension needing to access d3 Javascript on a remote website. But this Sankey extension problem may be unrelated to the VPN.

       

      I've tried researching the Qlik Community and there are a number of mobile VPN and server VPN problems but nothing clearly related to Qlik Sense Desktop. I'm stuck. What do I do?