6 Replies Latest reply: Jan 11, 2017 9:17 PM by VIcky Moore RSS

    Section access help

    VIcky Moore

      I’m hoping someone can help (and it’s something obvious that I missing) - I'm very new to Qlik Sense so forgive what may be some obvious mistakes.


       

      I have created an excel spreadsheet for me called ACL.XLSX which has four columns. The headers of these columns are:

      ACCESS, USERID, GROUP and CODE

       

      The section access in the data load editor looks like this:


      section access;

      //Create authorisation table

      LOAD

        ACCESS,

          USERID,

          GROUP,

          Upper(CODE) as %AUTHID

      FROM [$(vL.ImportPath)/ACL.XLSX]

      (ooxml, embedded labels, table is [Auth_Table]);

       

      section application;




       

       

       

       

       

       

       

       

      I get this error when I try to Load Data:

       

      Started loading data

       

       

      The following error occurred:

      Field not found - <ACCESS>

       

      The error occurred here:

      LOAD ACCESS, USERID, GROUP, Upper(CODE) as %AUTHID FROM [lib://Import (win-gefg5c269k8_vmoore)/ACL.XLSX] (ooxml, embedded labels, table is [Auth_Table])

       

      Data has not been loaded. Please correct the error and try loading again.



       

       

       

      I know the vl.ImportPath is correct and I know the name of the file is correct (I know this because I changed it in the section access to be “ACL123.XLSX” and I got a different error saying it couldn’t find the file.


       

      I just cannot understand why it can’t find the field “ACCESS”. If I comment out that line, I get the same error message but it says it can’t find “USERID”.

       

      Is it something obvious or something I am missing?


      I have tried all using square brackets for the field names, quotes etc. but still get the same error message.