6 Replies Latest reply: Jan 31, 2017 4:46 PM by Jawed Macknojia RSS

    Date problems on profile page

    Jawed Macknojia

      The member since date is not calculated correctly on profile page. I joined the community on October 3, 2016 and it says 10 March, 2016.

       

      It's not a big issue but I just wanted to let you guys know about the problem.

       

      Thanks,

      J.

        • Re: Date problems on profile page
          Marcus Sommer

          It's the same for me and I'm not sure about it but I think that another and earlier registration-date by the download- or customer portal or something similar will be used as the join-date because you are the same user in all these systems. Maybe sli could confirm it respectively which date will be taken for it.

           

          - Marcus

          • Re: Date problems on profile page
            Jeremy Latimer

            Hi Jawed,

             

            Thanks for your post. I checked your profile and am seeing the date of October 3, 2016 which you said was correct:

             

            2017-01-27_12-40-05.png

             

            Is this where you were seeing the March date?

             

            Also, it's an interesting note that March 10 and October 3 can both be abbreviated as 10/3 or 3/10, depending on the language.

             

            Thank you,

            Qlik Community Team

              • Re: Date problems on profile page
                Jawed Macknojia

                Yes, that is the page. I agree it's a language/locale settings.

                 

                But the issue is with conversion, I have set English as language and Australia as locale but date still shows March 3, 2016. When I change the locale to United States it shows October 3, 2016, which is not correct. Language/locale is UI stuff and current format of date is regardless of it. If we have date shown in MM/DD/YYYY or DD/MM/YYYY format than we can make it a language/Locale issue.

                 

                My Hypothesis:

                If we consider this conversion correct than I believe the date format conversion, at the time of registration was incorrect and it was stored incorrectly in the database. Why? My guess is, the default language/locale is English/US when I registered on October 3, 2016 and the date stored as March 10, 2016 after conversion. Therefore, when I change Language/Locale to English/AU it gives me March 10, 2016 but for English/US it gives me October 3, 2016.

                 

                Thanks,
                J.