4 Replies Latest reply: Jan 30, 2017 4:59 PM by ben anderson RSS

    Section Access Denied Users - No "Access Denied" Message

    ben anderson

      Hi,

       

      We've implemented Section Access in one of our apps and it's working, but denied users are not receiving an "Access Denied" message.

       

      Do we need to enable something on the QMC or add anything to the script?

       

      Also, can we customize the error message?

       

      Thanks,

       

      Ben

        • Re: Section Access Denied Users - No "Access Denied" Message
          Mark Ritter

          On my system I have seen an Access Denied message when try to open the App.  There is no other setting and I don't think you can change it.

           

          Are you certain that it is working?

           

          What happens?

            • Re: Section Access Denied Users - No "Access Denied" Message
              ben anderson

              Hi Mark,

               

              Section Access is working and reducing data correctly for users that are assigned access to the app.

               

              For users that do not have access (aren't included in the Section Access table at all) they do not receive an "Access Denied" message. When "denied" users open the app, the Qlik bubbles keep popping up without an error message and the app doesn't open.

               

              This is OK because the "denied" users can't access the app, BUT users will not know that the app isn't opening because they don't have access and when the app is "hung up" it's maxing out memory usage on the server.

               

              Thanks,

               

              Ben

            • Re: Section Access Denied Users - No "Access Denied" Message
              ben anderson

              UPDATE:

               

              I'm still experiencing this issue on our Qlik Sense server.

               

              To test, I create a very simple app with section access as follows:

               

              Section Access;

              LOAD

                  UPPER("ACCESS") as ACCESS,

                  UPPER("USERID") as USERID,

                  UPPER(LCO) as LCO

                  INLINE [

              ACCESS, USERID, LCO

              ADMIN, AA\ADMIN1, *

              USER,    AA\USER01, B

              USER,    AA\USER01,  C

              USER,    AA\USER01,  D

              USER,    AA\USER01,  E

              USER,    AA\USER01,  F

              USER,    AA\USER01,  G

              USER,    AA\USER01,  H

              USER,    AA\USER01,  I

              USER,    AA\USER01,  A

              USER,    AA\USER01,  J

              USER,    AA\USER01,  K

              USER,    AA\USER01,  L

              USER,    AA\USER01,  M

              ADMIN, AA\ADMIN2,            *

              ADMIN, INTERNAL\sa_scheduler, *

              ];

               

              SECTION APPLICATION;

               

              LOAD

                  UPPER(LCO) as LCO,

                  Score

                  INLINE [

                  LCO,  Score

              A,    1

              B,    2

              C,  3

              D,    4

              E,    5

              F, 6

              G, 7

              H, 8

              I,  9

              J, 10

              K,      11

              L,  12

              M,      13

              ];

               

               

              Again, section access is working correctly, BUT when an unauthorized user tries to open the app they are not receiving an "Access Denied" message, the Qlik bubbles keep popping like the app is loading (but it never loads).

               

               

              Thanks,

               

              Ben

              • Re: Section Access Denied Users - No "Access Denied" Message
                ben anderson

                Qlik informed me that this is a known bug with Qlik Sense 3.1.