1 Reply Latest reply: Feb 7, 2017 3:54 PM by Michael Tarallo RSS

    Mysql set keyword not working in Qlik

    Ankit Tr

      Hi All,

       

      Following sql query throws an error in Qlik Sense, cannot find any reason or an alternative.

       

       

       

       

      Tablename:

      load *; 

      set @rank=0;

      set @rank1=0;

      sql

      select t1.id,t2.id,t1.user_id,t2.user_id,t1.created_at,t2.created_at

      from ( select @rank:=@rank+1 as rank, requested_trips.id, requested_trips.user_id,created_at

      from requested_trips  order by user_id, created_at) t1 inner join (

      select @rank1:=@rank+1 as rank, requested_trips.id, requested_trips.user_id,created_at

      from requested_trips order by user_id, created_at) t2 on t1.rank=t2.rank+1

        • Re: Mysql set keyword not working in Qlik
          Michael Tarallo

          Hello Ankit -

           

          Welcome to the Qlik Community. I can appreciate you asking for support, but can you please provide some more information? Please provide a screen shot, error message, etc.

           

          Thanks

           

           

          When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

           

          Regards,

          Michael Tarallo (@mtarallo) | Twitter

          Qlik