13 Replies Latest reply: Mar 9, 2017 9:19 AM by Elena Kusterer RSS

    Data Load Progress

    Elena Kusterer

      Hi everyone!

       

      I have been using QlikView but my office will be moving to Qlik Sense. I tried downloading the Qlik Sense Desktop to see what I could do. At first I thought I was having issues because Qlik Sense did not have access to the network drive (shared drive) where my data was. So I moved the data to my hard drive. I am still having the same problem.  It's been over 5 minutes and my data has not loaded. The data is 50 lines of excel data and I made sure to scrub the data before I tried to bring it in.

       

      loadscreen.png

       

      Is this normal for when you are first loading data, even if it is just like 50 records? There are about ten columns for each record.

       

      Thanks for your help!

       

      Message was edited by: Elena Kusterer This is the test app that I have been working with. I was able to get the data to load on the Cloud version of Sense but still not on the desktop. I tried using the Data Manager in Sense but I kept getting an error.

        • Re: Data Load Progress
          Fei Xu

          What is your script?

          • Re: Data Load Progress
            Yddona Lyn Aranzanso

            you can try to reopen and reload the file. Usually when the abort button is grayed out, I think it already hanged and sometimes the file becomes corrupted. So try to close Qliksense and load again.

            • Re: Data Load Progress
              Chennaiah Nallani

              Attach same app

              • Re: Data Load Progress
                Arnaldo Sandoval

                Hi Elena,

                 

                There are few differences between Qlik Sense from Qlik View, I will try to assist you with some based in your post:

                 

                Settings.ini

                This file is located in your workstation at: Documents\Qlik\Sense; the files tells Qlik Sense where to find the files you will be working with.

                 

                Find the line with the name DocumentDirectory; don't worry If you do not find it, a default installation may not required it

                 

                DocumentDirectory=\\<the network share path to the folder where you will work with Qlik Sense>

                 

                You better make a backup of the Settings.ini file before changing it.

                 

                Scripts:

                You did not say if you are using a QlikView script within QlikSense, but I suggest to check the script's Connections, those are defined on the right panel.

                 

                You can create Connections to network shared basically by entering the whole path, using the \\Sever\Share_Name\path-to-the-folder-containing-your-data

                 

                Hope this helps,

                  • Re: Data Load Progress
                    Elena Kusterer

                    I opened settings and all it has in it is:

                     

                    [Settings 7]

                      • Re: Data Load Progress
                        Arnaldo Sandoval

                        Elena,

                         

                        Then on the line just below the [Settings 7], type

                        DocumentDirectory=\\Your_Share_Sever\Your_Share_Name\The_Path_to_your_applications


                        It may end looking like the one below:

                        [Settings 7]

                        DocumentDirectory=\\QlikSvr\Qlik_Data\Development

                         

                        Where:

                        QlikSvr is the name of the server containing the network share.

                        Qlik_Data is the name of the network share

                        Development is one of the folders in the network share.

                         

                        Please make sure there is an empty line after the DocumentDirectory line.

                          • Re: Data Load Progress
                            Elena Kusterer

                            Hi! So I did update, the way I think you said to, but now the program is stuck in Opening the hub. I've attached my updated settings for you to take a look at. I made a back up in case I messed anything up.

                              • Re: Data Load Progress
                                Arnaldo Sandoval

                                Hi Elena,

                                 

                                I did not see your attachment, I took an screenshot of one of my Settings.ini files; the third line should be empty, with at least one space, otherwise Qlik Sense will hang on the hub forever.

                                 

                                Settings-Sample.png

                                 

                                Hope this helps,

                                • Re: Data Load Progress
                                  Arnaldo Sandoval

                                  Hi Elena,

                                   

                                  I found your attachment, you do have extra lines at its end, more than one, we keep just one, a second thing with your Settings.ini file compared with ours, its path ends with a trailing backwards \ (we end with the folder name) and finally, your folder name contains lots of punctuation characters, like dashes and dots, we avoid those characters with our folders structures (old habit, Windows behave crazy with them) so perhaps you should enclose the path is [ ] (a way to tell Qlik to ignore weird characters, but I can't test this idea locally.

                                   

                                  HTH

                                    • Re: Data Load Progress
                                      Elena Kusterer

                                      Thanks so much for your help. I was able to get Qlik Sense to actually load this time but it is still having issues with trying to load my data.

                                        • Re: Data Load Progress
                                          Arnaldo Sandoval

                                          Hi Elena,

                                           

                                          That could be related on how you created the connections (Folder Connections) in your applications, as a Rule of Thumb, it is preferable to always avoid drive letters in the path you enter in your Folder Connections, the drive letter is local to the computer hosting the application, if you write a Qlik Sense Application inside the server with connection's path referencing the D-Drive, then when you run the same application in your local machine, your D-Drive is absolutely different.

                                           

                                          It is better to always use Universal Naming Convention (UNC): \\server_name\share_name\path, this way your application will always find its QVDs.

                                           

                                          Folder-Connection.png

                                          Hope this helps,

                              • Re: Data Load Progress
                                vivek pv

                                Hi Elena,

                                 

                                This was also happened for me many times. I deleted old app and recreated it. and the script ran successfully for me.

                                 

                                I

                                 

                                 

                                 

                                 

                                Thanks,

                                Vivek