5 Replies Latest reply: Mar 22, 2017 8:45 AM by Tyler Waterfall RSS

    Goverance Dashboard 2.0.2

    alvinford ford

      Hi ,

       

      Facing the below error , when configuring Governance Dashboard 2.0.2.qvw .

      Request your help to resolve this.

       

       

      Thanks in Advance ..

      Alvin Ford ..

        • Re: Goverance Dashboard 2.0.2
          Tyler Waterfall

          Hi Alvin,

          Yes, I've see this before. Something with the initialization of variables gets mixed up and you get an old path variable popping up.

          Try opening the variable overview, search for definition "\\qv-bos10.rdlund..." and replace it with "c:\programdata\qliktech\DistributionService"

          (Note: Issue captured in GOVDASH-147)

            • Re: Goverance Dashboard 2.0.2
              alvinford ford

              Hi Tyler,

               

              Thanks You for your reply. I have downloaded the Governance Dashboard again and refreshed it, I am not getting the same error but encountering the following error. Not sure what is the issue and the important thing would like to mention is , trying to configure this Governance Dashboard in Windows Server 2012 R2 environment.

               

              Can you please help to look into this issue.

               

              Thanks ,

              Alvin

                • Re: Goverance Dashboard 2.0.2
                  Tyler Waterfall

                  Ah, the Prescription Tracker.qvw demo app! (Scanning this crashes certain versions of QlikView)

                  Remove it from C:\Programdata\Qliktech\Documents and try the reload again.

                   

                  Also, the "regular" metadata errors "An invalid number..." is more of a warning than a fatal error stating that the metadata for the specific qvw or qvd couldn't be read.

                    • Re: Goverance Dashboard 2.0.2
                      alvinford ford

                      Hi Tyler,

                       

                      Thank You for your reply. Finally I have realized that configuration is different for clustered environment. Configured it now and reload is successful, but can't see any data related to server and sessions.

                      We have the following environment i.e.

                      Two application Servers which are clustered

                      1)  PRDAPP101

                      2)  PRDAPP102

                      One Publisher Server

                      1) PRDPUB101

                      One NAS Server

                      1) PRDDATA101

                       

                       

                      Created the folder Structure as below

                      Configured the config file as below

                       

                      //// Environment Settings
                      // 1. How many distinct "Servers" (Source Document folder(s) and standalone or clustered Server/Publisher) will be scanned?
                      SET vHowManyServers = 2;

                      // 2. How many Aggregators are needed?
                      SET vHowManyAggregators = 1;

                      //3. How many years of server log history is needed?
                      SET vHistoricalYears = 1;           //  Years back from today of server log history.  For example, 1 = one year back (last 365 days), 2 = last 2 years, etc.


                      ///// ==========================
                      //// "SERVER" Configuration
                      // Start with 1 and increment sequentially (do not skip numbers!)

                      // Server 1
                      SET vMultiCluster_ProfilePath_1 = 'C:\ProgramData\QlikTech\Governance_1.1\profiles\Cluster\PRDAPP101'; // Profile Directory on Config page
                      SET vMultiCluster_FilePath_1a = '\\PRDDATA101\d$\QVPublish';     // Documents: File Paths to Scan
                      SET vMultiCluster_ServerPath_1 = 'C:\ProgramData\QlikTech\QlikViewServer';    // Has Server?: Log Path
                      SET vMultiCluster_HasAudit_1 = 1;             // Has Audit logging?:1 = Yes, 0 = No.
                      SET vMultiCluster_PublisherPath_1 = '\\PRDPUB101\QVPubAppFolder';    // Has Publisher?: Log Path
                      SET vMultiCluster_QVPRPath_1 = 'C:\ProgramData\QlikTech\ManagementService\QVPR';    // Repository Path
                      SET vMultiCluster_PubDateTimeFormat_1 ='CCYY-MM-DD H*24:MI:SS';       // DateTime format of Publisher task result logs (default = CCYY-MM-DD H*24:MI:SS)

                      // Server 2

                      SET vMultiCluster_ProfilePath_2 = 'C:\ProgramData\QlikTech\Governance_1.1\profiles\Cluster\PRDAPP102';
                      SET vMultiCluster_FilePath_2a = 'C:\ProgramData\QlikTech\Governance_1.1\profiles\Cluster\PRDAPP101';
                      SET vExcludeFiles_or_Folders_2a = 'QVX_LastRun|QVD_Historical'; 
                      SET vMultiCluster_ServerPath_2 = '\\PRDAPP102\c$\ProgramData\QlikTech\QlikViewServer';
                      SET vMultiCluster_HasAudit_2 = 1;
                      SET vMultiCluster_PublisherPath_2 = '';
                      SET vMultiCluster_QVPRPath_2 = '';
                      SET vMultiCluster_PubDateTimeFormat_2 ='CCYY-MM-DD H*24:MI:SS';  // What's your datetime format?

                       

                      ////====================================
                      /// AGGREGATOR Configuration
                      //// Start with 101 and increment sequentially (do not skip numbers!)

                      // Aggregator 1

                      SET vMultiCluster_ProfilePath_101 = 'C:\ProgramData\QlikTech\Governance_1.1\profiles\Cluster\Aggregator';
                      SET vMultiCluster_FilePath_101a = '$(vMultiCluster_ProfilePath_1)';
                      SET vMultiCluster_FilePath_101b = '$(vMultiCluster_ProfilePath_2)';
                      SET vClusterName_101a = 'PRDAPP101';    // Add unique name for each "cluster"
                      SET vClusterName_101b = 'PRDAPP102';


                      ////==================================
                      ////  GLOBAL Aggregator Configuration

                      // GLOBAL Aggregator

                      SET vMultiCluster_ProfilePath_201 = 'C:\ProgramData\QlikTech\Governance_1.1\profiles\Cluster\Global';
                      SET vMultiCluster_FilePath_201a = '$(vMultiCluster_ProfilePath_101)';

                       

                      Not sure if I configured it correctly. Cannot see any data at Server sheet and Session Sheet

                       

                       

                       

                       

                      Please guide in the right direction.

                      Thanks in Advance...

                       

                      Regards,

                      Alvin