1 Reply Latest reply: May 11, 2017 9:14 AM by Gregory Crisman RSS

    nPrinting TLS Handshake Error

    Gregory Crisman

      Using nPrinting 17.3 and Qlik Sense 3.0 SR3

       

      Recently installed nPrinting 17.3 on a client machine.  Using qlik best practices we made sure that this is a separate machine from the Qlik Sense Server that they are currently using.

       

      Installation process went smooth and everything seems to be up and running.  Was able to upload my Qlik Sense Certificates and the connection to the nPrinting engine is set up and has a status of online.

       

      When i go to make my first connection however, i run in to an issue.  I initially receive a Connection Status = 'Connection Error' and under Cache Status i see "Error Request has been purged due to connection errors".  I've checked the log files and i see this information:

       

      TLS Handshake Error.png

      Then after a while, if i look back at my NPrinting Web Console, under Connection Status i see 'Ok' however the Cache Status still has the same error...  When i try to reload the metadata, i am back where i started and receive the 'Connection Error' status.

       

      Couldn't necessarily find any information in troubleshooting or on forums that were similar so was looking for some guidance as to what could be causing this error.

       

      Appreciate any help or suggestions!

        • Re: nPrinting TLS Handshake Error
          Gregory Crisman

          Was able to fix this issue if anyone runs in to the same problem.

           

          Appears the TLS Handshake error is due to errors in communication between NPrinting and the source system (Qlik Sense or Qlikview).  To fix this we went through a full reinstall of all three NPrinting programs (server, engine, designer)

           

          Please ensure when installing, that the user installing the tools is using a service account logged on the machine, has Administrator rights on the machine that the tools are being installed on, as well as 'Log on as Service Rights' enabled. Not to mention is a RootAdmin in Qlikview or Qlik Sense.

           

          Although, we THOUGHT we were following the installation directions to a T, when installing i was using my Windows User logged on to our NPrinting Machine, and entering in the Service Account credentials when prompted, we received the error.  So please be sure that you are logged on to the machine as the service account username when completing the installation process.

           

          This seemed to fix our issue.