7 Replies Latest reply: May 4, 2017 11:19 AM by Dimitrios Apostolopoulos RSS

    SAP Connector 6.3.2 doesn' t work on the Server

    Dimitrios Apostolopoulos

      Hello, everyone, i really want your help right now...

       

      We bought the QlikView SAP Connector and we succesfully installed it on two desktops and we loaded data from our SAP BW 7.4...

       

      We tried to install the connector in the server where QlikView Server is...

      The installation completed succesfully and there was already installed a SAP GUI on this machine but when we tried to make a test connection everything went wrong...

       

      BeXConnector and SAPSqlConnector return this kind of errors when we just select them from the drop down list:

       

      Untitled.png

      The other connectors don' t respond in that way when selected but when we try to establish a connection a registration window pops up:

       

      Untitled.png

      Keep in mind that the QlikView Server is already registered and when we use the license number and control number of the SAP Connector the following message pops up:

       

      Untitled.png

      We uninstalled the QlikView SAP connector and the SAP GUI and we installed them again but nothing changed...

       

      Any help will be really appreciated...

        • Re: SAP Connector 6.3.2 doesn' t work on the Server
          Peter Cammaert

          Care to post the details of your server? What Windows OS? 64-bit (just to be sure)? VM? Citrix? Which version of QlikView (Server and Desktop, please include the SR nr)

           

          Are you running these test using an administrator-level account? Or even better, using the account that is running the QlikView services? In QV Desktop on your server?

          Are you able to find and open the LEF? IT looks like a permissions problem to me, but that could be a result of encountering other problems before that one.

           

          Assuming that there is no Connector log being created since you are only configuring, is there any message to be found in the Windows Event logs?

           

          The first screenshot is familiar to me, but in my case it's usually caused by another connector (Server Object connector) in QV Desktop. Probably too old to execute properly.

            • Re: SAP Connector 6.3.2 doesn' t work on the Server
              Dimitrios Apostolopoulos

              Hello Peter, i wiil try to reply to your questions:

              • The server is a VM, Windows Server 2008 R2 SP1(64bit)
              • The system detail are the following:
                Untitled.png

              • The version of QlikView Desktop is 12.10.20000.0 SR2 (64bit)
              • The version of the QlikView Server is 11.20.12235.0 (64bit)
              • I am running the test with my account that has adnibitrator rights on the server and with the user that runs the QV Services on the Server, on QlikVeiw Desktop on the server. The problems are the same in both cases.
              • I found the LEF file for the QlikView  Server in C:\ProgramData\QlikTech, all ok.
              • I didnt' t found the LEF for the QlikView SAP Connector in the C:\Program Files\Common Files\ QlikTech\Custom Data\QvSAPSqlConnector so i placed it there manually. This action solved the problem for all the connectors except Bex and SAPSql that keep popping up the stopped running error!!!
              • In the event logs i keep getting the following errors for both Bex connector and SAPSQL connector
                Untitled.png
              • The .NET framework version installed on the server is 4.6.2
            • Re: SAP Connector 6.3.2 doesn' t work on the Server
              Dimitrios Apostolopoulos

              It seems to be an issue with the QlikView Server version that i am running (11.2 SR12) that causes various problems with the KernelBase.dll...

              In the support portal they suggest to upgrade to another sr higher than 12...

               

              I'll give it a try...

              • Re: SAP Connector 6.3.2 doesn' t work on the Server
                Dimitrios Apostolopoulos

                I upgraded the server to SR13 but the problenm is still there...

                I noticed that the connectors that aren't working are thw only ones of the connectorw which are .exe files, not .dll files...

                I think that maybe it has something to do with my problem, maybe a configuration on the OS of the server...