0 Replies Latest reply: May 4, 2017 8:11 PM by Claudia Ledesma RSS

    SAP BW OLAP Connection

    Claudia Ledesma

      Hello Qlik Community,

       

      I am a long time user with QlikView and cannot figure out what the problem is.

       

      We are connection to SAP BW via SAP OLAP Connector.  I can see the InfoCubes and the query.  I get a script error but the log shows very little informaton.

       

      Screen shot of cube:

       

       

      Below is a simple script where I an only grabbing one dimension to try and debug the issue.

       

      [ZOEF_M01/QZOEF_M01_5024]:

      Load *;

      Select PseudoMDX D (
      Dimensions (
      [ZBPCSACC] ())
      Measures (
      [45K2ONGJAFEDIZQNBNYJIQ6VE].[45K2ONO7TE031MA3HI0VSS5L6]),
      //MTD
      Variables (
      [!V000001] (I = [ZOPERCOMP].[AUC]),
      [!V000002] (I = [0CALYEAR].[2017]),
      [!V000003] (I = [0CALMONTH2].[02]),
      [!V000004] ()),
      From (ZOEF_M01/QZOEF_M01_5024));

       

      Log:

       

      2017-05-05 09:47:01 Progress Connected to SAP with C:\Program Files\Common Files\QlikTech\Custom Data\QvSAPConnector\QvSAPOLAPConnector.dll 5.7 SR1, 10958

      2017-05-05 09:47:01 Progress Log: 1

      2017-05-05 09:47:01 Progress Logpath:

      2017-05-05 09:47:01 Progress LogFile: QvSAPOLAPConnector

      2017-05-05 09:47:03 Progress Connected

      2017-05-05 09:47:05 Progress Creation of function OCS_GET_SYSTEM_INFO returned after 00:00:02

      2017-05-05 09:47:05 Progress SystemVersion is 740. Support pack level is 0006

      2017-05-05 09:47:05 Progress Statement is: SELECT PSEUDOMDX D ( DIMENSIONS ( [ZBPCSACC] ()) MEASURES ( [45K2ONGJAFEDIZQNBNYJIQ6VE].[45K2ONO7TE031MA3HI0VSS5L6]), VARIABLES ( [!V000001] (I = [ZOPERCOMP].[AUC]), [!V000002] (I = [0CALYEAR].[2017]), [!V000003] (I = [0CALMONTH2].[02]), [!V000004] ()), FROM (ZOEF_M01/QZOEF_M01_5024))

      2017-05-05 09:47:05 Progress GlobalOptions: m_TryWithoutSlicing - Yes

      2017-05-05 09:47:05 Progress GlobalOptions: m_OptimizeByReducingOnCharacteristic - No

      2017-05-05 09:47:07 Progress Disconnected

       

      Has anyone encountered this problem? We have checked authorisation levels in SAP BW and we can execute the query in other BI tools.

       

      Thanks - Claudia