1 Reply Latest reply: May 23, 2017 5:03 AM by Diana Lixandroiu RSS

    QL##f - SqlState: 42000, ErrorCode: 4294965391, ErrorMsg: [Microsoft][ODBC Microsoft Access Driver] Not a valid password.

    Iftikhar Ali

      Hi

      I am new to qlikview and want to access data from MS Accss database (.mdb) format.

      i follow the following Steps

       

      Step  1 :  Install AccessDatabaseEngine and AccessRuntime_x64_en-us

      Step  2:  Create odbc conncection to my database  from script editor

                    Connection String

      ODBC CONNECT TO [MQTU;DBQ=Path\Database.mdb] (XUserId is JCTafQRMNLacWNC, XPassword is aRSBXRdNSLZEDSVOPbFB);

      Step  3 : Now i load all the required tables from my database

      Step  4: Now Click Reload button to load data form database and it give me an  error

       

      SQL##f - SqlState: 42000, ErrorCode: 4294965391, ErrorMsg: [Microsoft][ODBC Microsoft Access Driver] Not a valid password.

       

      if my password is wrong then how it load my tables

        • Re: QL##f - SqlState: 42000, ErrorCode: 4294965391, ErrorMsg: [Microsoft][ODBC Microsoft Access Driver] Not a valid password.
          Diana Lixandroiu

          Hi, I was looking for the same issue and I got to your post (btw, new to these things as well).

          I think I just managed to solve my issue. I am using a test MS Access DB in .accdb format and 64 bit system and QV12.

          Here is what I have done:

          - downloaded ODBC driver 64 bit from here, although I am still not sure if this was necessary or not Download Microsoft Access Database Engine 2010 Redistributable  from Official Microsoft Download Center

          - installed driver: opened ODBC Data Sources Administrator (64-bit) > System DNS tab > Add button > selected Microsoft Access Driver (*.mdb, *.accdb) > in Data Source Name I typed a name for the connection, in Database I navigated to the location where I had my MS Access DB (mine was stored locally), in Advanced I typed the login name and password of the DB and on Options menu I checked "Exclusive" option.

          - in QV I used ODBC option and then selected the connection I previously created and I set the same user and password I put when I created the ODBC connection.

          I think that the trick for me was to select the Exclusive option; I tried running QV with a connection that didn't have the Exclusive option checked and it didn't work, got same error as you did.

           

          Hope this makes sense and works for you.

          Have fun,

          Diana