3 Replies Latest reply: May 22, 2017 4:55 PM by victor daniel rojas RSS

    Qlik sense section access

    Carl Hodder

      I've searched around but can't find anyone having this issue (Qlik Sense 3.2 SR2).

       

      I have an app in which I'm trying to get section access working, the issue I have is that it doesn't do anything.

      First block of app:

      SECTION ACCESS;

      LOAD * INLINE [

      ACCESS, USERID, %AUTHID, OMIT

      ADMIN, DOMAIN\ME, ,

      USER, DOMAIN\ME, '<ANY>' ,

      USER ,DOMAIN\ME, 'TEXTKEY' ,

      ];

      SECTION APPLICATION;

       

      (Table linking %AUTHID is built lower in app and shows in data model)

       

      I've tried limiting everything down to just:

      USER ,DOMAIN\ME, 'FAKEKEY' ,

      Or removing 'OMIT' field, changing name of '%AUTHID' to be REDUCTION, USERID to NTNAME and generally messed around a lot.

       

      I expected to get blocked from my own app, but in all instances I can still see all the data. Do I need to enable this functionality in the QMC first, or are there user security roles that bypass section access? I can't find any mention of this in the documentation, only that I need to have the above block.


      Any help would be greatly appreciated!

        • Re: Qlik sense section access
          Carl Hodder

          OK that's odd - I opened the app up this morning and got an 'Access is denied' (Which is possibly one of the first times I've been excited to see a message like this).

           

          I opened without data to put entries back in section access table. Works. Then tried to remove them again and once again have full viewing access with:

           

          ACCESS, USERID, %AUTID, OMIT

          USER, DOMAIN\ME,  ,

           

          At a guess it appears to be some sort of caching issue (maybe). Tried different browsers (IE11 & Chrome), so at a bit of a loss again.