7 Replies Latest reply: Jul 14, 2017 11:56 AM by Alan McGrath RSS

    Qlik Sense - cannot open file (QVD)

    Alan McGrath

      I have an app on the hub that is working fine.  I am now attempting to add in section access so I duplicated the app to my "Work" section.  However, now when trying to load from any QVD it gives me the error of cannot open file.   I duplicated a version ealier today and it loaded fine.  I did nothing different this time.  Any idea why it won't open the QVDs?  All my QVDs are in the proper folder on the server, all have data, and have been opened previously.

      Update:  I duplicated the file again and then I was able to load.  However, I just tried it again and now facing the same issue.  I tried duplicating again but it did not work this time. I deleted from QMC then duplicated again, still no luck.  I can't seem to figure out why it will not load.  Any ideas?

        • Re: Qlik Sense - cannot open file (QVD)
          m s

          not sure, but are you unable to open your applications AFTER you added the Section Access and Reloaded the application?

          it might indicate that your section access is incorrect... maybe share that part here?

          • Re: Qlik Sense - cannot open file (QVD)
            Alan McGrath

            Update:  I have found this issue has nothing to do with section access.   I can load fine with or without section access several times but after that I get the error "Cannot Open File" even though all my QVDs are there and have loaded successfully before that.

            If I delete the app from the "Work" section, Duplicate it from the stream, then close the hub for about 15 minutes and then reopen it will again work with no issue.  I am assuming this is some sort of bug with Qlik Sense.

            Further, I am now running into the same issue with a file that is ONLY in my "Work" section (not deployed to a stream).  However, the workaround mentioned above doesn't wok.  It no longer will load at all even though I loaded it several times successfully today.

            Very frustrating!

            Anyone have any ideas as to why this happens or how to fix it?

            • Re: Qlik Sense - cannot open file (QVD)
              Alan McGrath

              I have an update on this in case anyone experiences the same issue.  After working with our server team they found the reason this was happening.  I no longer have issues reloading

               

              Earlier, it was configured only with Central server node NOT Rim node. (requests which were going to Rim node was failing earlier)

              We configured QlikSense services to run with service account on both the nodes.