2 Replies Latest reply: Jun 14, 2017 11:43 AM by Olivier ROBIN RSS

    Problem connecting qlik server to LDAP

    Olivier ROBIN

      Hi,

      when configuring connection to LDAP, I receive this error message :

       

      14/06/2017 11:47:55.9772795Information(ActiveDirectory.ActiveDirectoryProvider) Looking up RootDSE: LDAP://ldapservername/RootDSE
      14/06/2017 11:47:55.9929061Warning(ActiveDirectory.ActiveDirectoryProvider+CachedDirectoryEntryHolder) Fetching directoryentry LDAP://ldapservername/RootDSE failed: Le nom d’utilisateur ou le mot de passe est incorrect.
      14/06/2017 11:47:55.9929061Warning(ActiveDirectory.ActiveDirectoryProvider) Exception while initializing LDAP://ldapservername: Setting up connection failed; Le nom d’utilisateur ou le mot de passe est incorrect.
      14/06/2017 11:47:55.9929061Error(DSC.DirectoryFramework) setup path not successful for user 'username' at 'LDAP://ldapservername': System.Exception: Setting up connection failed; Le nom d’utilisateur ou le mot de passe est incorrect. ||  ||    à ActiveDirectory.ActiveDirectoryProvider.CachedDirectoryEntryHolder.get_Entry() ||    à ActiveDirectory.ActiveDirectoryProvider.GetDirectoryEntry(String path) ||    à ActiveDirectory.ActiveDirectoryProvider.SetupPath(String _path, String _username, String _password) ||    à DSC.DirectoryFramework.SetupResource(Guid id, String type, String path, String username, String password, IDictionary`2 newSettings)
      14/06/2017 11:47:55.9929061Warning(DSC.DirectoryFramework) Setting up adDSP 'LDAP://ldapservername' wasn't successful: Setting up connection failed; Le nom d’utilisateur ou le mot de passe est incorrect.

       

      where ldapservername is the name of the ldap server

      and username is the username which has access to this server

      of course, the password iw typed correctly

       

      if I use a tool such as AD Explorer with the same user and password, I have no problem

      And this user is already used to access another LDAP server on the QV server and it works perfectly

      Any idea ?