6 Replies Latest reply: Jun 19, 2017 6:01 PM by Brian Head RSS

    Difficulty with NULLASVALUE

    Brian Head

      Hi all,

       

      I'm new to Qlik. I've generally been able to answer questions via previous discussions (thanks to everyone who contributes). Unfortunately, I have not been able to figure out an issue I'm having with NULLASVALUE using previously answered questions in the community forums.

       

      Need: my need is to be able to select null values in a sheet table which I will then export. I'm pulling from several QVD loaded tables.

       

      Problem: I've included 'set NULLASVALUE='<NULL>';' in each applicable sheet of a load script and also tried placing the statement in a sheet of other set statements (although I did these at different times) at the beginning of the load. The example code below includes a "where 1=1" statement that was recommended in another community post because of issues with optimized QVDs. I've tried loading with and without this statement.

       

      I'm having issues with the '<NULL>' sometimes being written and available, other times getting blanks, and other times getting a "-" for the null value as is default.

       

      Any suggestions would be most welcome.

       

      ****************************

      GIFTUDFtemp:

      NullAsValue*;

      LOAD

        "Gift ID",

         [Gift Alt Group Code],

         [Gift Mission Flag]

      FROM [QVD]

      (qvd)

      where 1=1;

      ****************************

       

      I've replaced the QVD just to ensure I'm compliant with organizational privacy policies.

       

      Thank you,

      Brian