1 Reply Latest reply: Jun 27, 2017 10:03 AM by Steve Dark RSS

    macro send Email with office 365

    CHRISTOPHE BEZOT

      Hi,

      I can't send a mail with office 365, i have allready reed all de blogs.

       

      with an other un SMTP server it's ok.

       

      this is my script :

       

      ' Server Configuration
      msgConf.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusing") = 2
      msgConf.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserver") = "smtp.office365.com"
      msgConf.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserverport") = 25
      msgConf.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpusessl") = True
      msgConf.Fields.Item("http://schemas.microsoft.com/cdo/configuration/UseSSLForSMTP") = True

      msgConf.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate") = 0
      msgConf.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusername") = "utilisateur@domaine'
      msgConf.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendpassword") = "password"

      msgConf.Fields.Update

       

      Please help me, thank

        • Re: macro send Email with office 365
          Steve Dark

          Hi Christophe,

           

          There are issues with sending email with Office365 (and GMail) because QlikView doesn't properly support the security protocols they use.

           

          I'm not sure if the same issues will be affecting using Qlik Web Connectors when sending.

           

          Here is a link to a post which describes how a tool called STunnel can be used to act as a proxy, effectively allowing you to send to a local SMTP host with no SSL security which is then relayed onto another host on a different port:

           

          Mail server settings

           

          Be aware that if you have something already on port 25 on your local machine you may need to use a different port.

           

          Hope that helps.

          Steve