3 Replies Latest reply: Jul 13, 2017 9:35 PM by Jonathan Lincheck RSS

    Qlik Sense Errors After NPrinting Configuration

    Jonathan Lincheck

      I am working to get the new June versions of Qlik Sense and NPrinting working together.  This is a demo environment, so everything is on one machine.

       

      I can install and configure both Sense and NPrinting fine, and gain access to the hub, qmc, and nprinting interfaces.  However, after following the directions for installing the certificates using the QMCCertificateInstaller, I lose access to Qlik Sense.  When I try to hit the hub or the QMC after doing this, I get this error:

      ----------------------------

       

      Can’t connect securely to this page

      This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.

       

      Your TLS security settings aren’t set to the defaults, which could also be causing this error.

      ----------------------------

       

      I am logged in to the computer as an administrator who is the start up user for the services.

       

      I have added localhost and my computer name to the local internet zone, and lowered the security settings for that zone.  I have tried installing just the client.pfx as well as forcing it to install all 3 pfx files.  I have tried disabling TLS 1.0 and 1.1. None of that helped.

       

      Any ideas on getting past this?  Thank you!

        • Re: Qlik Sense Errors After NPrinting Configuration
          Shyam Chaware

          Can you make sure TLS 1.2 is enabled? Once enabled restart all QlikSense services and see if that makes a difference?

          • Re: Qlik Sense Errors After NPrinting Configuration
            Bala Bhaskar

            Try this:

             

            Appears the TLS Handshake error is due to errors in communication between NPrinting and the source system (Qlik Sense or Qlikview).  To fix this we went through a full reinstall of all three NPrinting programs (server, engine, designer)

             

            Please ensure when installing, that the user installing the tools is using a service account logged on the machine, has Administrator rights on the machine that the tools are being installed on, as well as 'Log on as Service Rights' enabled. Not to mention is a RootAdmin in Qlikview or Qlik Sense.

             

            Although, we THOUGHT we were following the installation directions to a T, when installing i was using my Windows User logged on to our NPrinting Machine, and entering in the Service Account credentials when prompted, we received the error.  So please be sure that you are logged on to the machine as the service account username when completing the installation process.

             

            This seemed to fix the issue.

            • Re: Qlik Sense Errors After NPrinting Configuration
              Jonathan Lincheck

              Unfortunately, none of the replies solved the problem.

               

              However, what I found after a few reinstalls was that there was no reason to do the certificate step.  I skipped moving the certificate from Sense to NPrinting, and everything worked fine.

               

              I'm not sure if this is a change with the new version, or if the instructions are flawed or incorrect.  But moving the certificate broke the install and appears unnecessary.