6 Replies Latest reply: Aug 29, 2017 8:27 PM by praveena mundolimoole RSS

    The selections generated no data for this chart error in mashup

    praveena mundolimoole

      We are getting "The selections generated no data for this chart" in the chart intermittently even after applying all the necessary selections. Below are some of the observations.

       

      • QS Server Version : 3.2 SR1
      • This behavior is very in-consistent.
      • Same selections work in Qlik Sense without any issue, this seems to be only in the mashup.
      • There is no error in the server logs.
      • Tried reloading the chart by calling app object as shown below, this shows the same error.
        • app.getObject($("#viz_bar"), $("#viz_bar").attr("data-qlik-objid"));
        • Verified the promise method of the above, doesn't have any data in the hypercube.
      • Verified the current selections by calling current selections, this seems to be having all the necessary selections.
        • app.getList("CurrentSelections", function (reply) { });
      • Underlying data for the same selections rendering without any issue for straight table.
      • Refreshing the browser multiple times, renders the chart.
      • Below errors are logged in the browser console.

      error.png

      Any help on this would be highly appreciated! Thank You!!

       

      Regards,

      Praveena