4 Replies Latest reply: Aug 22, 2017 5:11 AM by pradosh thakur RSS

    qlikview with section access working fine in qlikview server but not opening in access point

    pradosh thakur

      hi

       

      i have a the following dummy section access piece which work perfectly fine for me when i run the .qvw file in my desktop qlikview or in my friend's but fails when run in server. please help me find out the reason . thanks in advance.

       

      star as *;

      section access;

       

      Section Access;

      LOAD * INLINE [

          ACCESS, NTNAME,REDUCTION

          ADMIN,R02\X1,' '

          USER,*,YES

      ];

      Section Application;

      LOAD * INLINE [

          REDUCTION_1,REDUCTION

      YES,YES 

         NO,NO

      ];

       

      the logic behind is X1 should be the admin and other user should be the USER and have access to restricted data.This is just a dummy data.

       

      this is working fine in my machine where i am the admin and my friends who is an user. everything from  strict exclusion to upper case in section access is done . the problem is it doest even open for  me in the access point.

       

      please let me know your suggestion.

       

      regards

      pradosh

        • Re: qlikview with section access working fine in qlikview server but not opening in access point
          Stefan Wühl

          Have you added the QV server service account user to the section access table with star symbol in REDUCTION field?

           

          Is your NTNAME user directory added in QMC?

            • Re: qlikview with section access working fine in qlikview server but not opening in access point
              pradosh thakur

              hi stefan

               

              thank you for the reply.

               

              I guess i was not specific. Here are the details.

               

              Lets say AD group has 10 users who should open the document. Out of the 10 , x1  need to see all data and others need to see restricted data. Users can be more so not added in the security table. admin are very less so their details can be loaded from a table from the data base or a qvd. Here to avoid confusion i have used inline.

               

              After i unchecked the strict exclusion and i was able to open the document  in Access point. but it is still considering me (x1 ) as user and i can see only the restricted data.

               

               

              star as *;

              section access;

               

              Section Access;

              LOAD * INLINE [

                  ACCESS, NTNAME,REDUCTION

                  ADMIN, R02\X1 , *

                  USER,*,YES

                   USER,DUMMY,NO

              ];

              Section Application;

              LOAD * INLINE [

                  REDUCTION_1,REDUCTION

              YES,YES

                 NO,NO

              ];

               

               

              is it because for user access * (star) is as NTNAME so it is considering everything as user and restricting data for  x1 also. and if i replace first line in section access as second and second as first will it make any diffrence? i.e

               

              Section Access;

              LOAD * INLINE [

                  ACCESS, NTNAME,REDUCTION

                      USER,*,YES

                    ADMIN, R02\X1 , *

                   USER,DUMMY,NO

              ];

              Section Application;

               

              i don't have publisher access as of now . will try it and let you know if it worked . please let me know if there is any solution to this .

               

              thanks

              pradosh