4 Replies Latest reply: Sep 5, 2017 6:36 AM by Constantin Leeb RSS

    QV SAP Connector: different versions in SAP and QV

    Constantin Leeb

      Hi everyone,

       

      We have the following setup:

      QlikView SAP connector version is 6.3.1 on the Uniper QlikView server side and version 5.90 on the SAP side.

       

      We now want to connect to an additional SAP system and therefore would need to install the transports there as well.

      Do we need to import the transports for 6.3.1 or 5.9?

       

      Best regards,

      Constantin

        • Re: QV SAP Connector: different versions in SAP and QV
          Kaushik Solanki

          Hi,

           

          Every new version of Qlik SAP connector has its own supporting transports and thus what ever version of SAP connector you install on Qlik Server, same version transport should be installed on SAP to have error free connection.

           

          Regards,

          Kaushik Solanki

          • Re: QV SAP Connector: different versions in SAP and QV
            Hakan Ronningberg

            Hi Constantin,

             

            There is a backwards compatibility:

             

            Connectors              Windows files      SAP transport (data extraction)

            SQL connector          6.3.1                      6.1.1 or later

            BEx connector           6.3.1                      6.1.2 or later

            Query connector        6.3.1                      5.80 SR2 or later

            Report connector       6.3.1                      5.80 SR2 or later

            Extractor connector   6.3.1                      5.80 SR2 or later

            BAPI connector         6.3.1                      5.80 SR2 or later

             

            So if you are using the Windows files of 6.3.1 you cannot use the SQL and BEx connector against the 5.9 SAP transports. I would recommend to import the 6.3.1 transports if possible. Or upgrade to the latest version 6.5.1. On the Qlik download site there is a Release Notes summary document where you can read about improvements and bug fixes that have occurred after 6.3.1.

             

            Regards,

            Hakan

            • Re: QV SAP Connector: different versions in SAP and QV
              Peter Cammaert

              That depends on which connector you are using for the transfer of SAP data.

               

              QlikView SAP Connector 6.3.1 will only talk to SAP systems that have transports that are no older than 6.1.1 (SQL Connector), 6.1.2 (BEX Connector) or 5.80SR2 (all others). Many Connectors don't even need transports. Check the release notes for further details.

               

              As Kaushik already explained, it's best to keep all installations in sync, and take the opportunity to upgrade all SAP Connectors and installations to the latest version (6.50) with the added advantage of important bug fixes (especially 6.3.2) for some connectors. If you cannot upgrade them all, use the transports of v6.3.1 and plan an upgrade of the 5.90 system.

               

              Best,

               

              Peter