2 Replies Latest reply: Sep 27, 2017 9:03 AM by Erik Wetterberg RSS

    ProxyErrorCode.1000 after installation of Qlik Sense September 2017

    Erik Wetterberg

      Hi,

      We have just installed Qlik Sense September 2017 on our server. The server actually had an installation of Qlik Sense June 2017, be this is not an upgrade, we uninstlled the old version and installed the new one.

       

      After the installation we get ProxyErrorCode.1000 when we try to connect.

       

      In the hub we actually get an error message saying 'The proxy is waiting for a new session', but when you look in the browser console what actually fails is a call to 'https://[server]/api/hub/about' with HTTP status 500 and ProxyErrorCode.1000.

       

      If we try to go straight to the app 'https://[server]/sense/app/[app id]' we get an error message that says 'No Qlik Sense engine found'. In the browser console we can see that the failing call is to 'https://[server]/api/capability/v1/list' with the same error (HTTP status 500 and ProxyErrorCode.1000).


      If we try our mashup, we get the error on the web socket. It looks like this:

      Capture.PNG

      The QMC works!

       

      We have tried restarting the services and adding the host to the whitelist, with as far as we can see no effect.

       

      Any suggestions?

       

      Erik Wetterberg

        • Re: ProxyErrorCode.1000 after installation of Qlik Sense September 2017
          Erik Wetterberg

          In the proxy log I find this:

          123 11.24.0.0 20170927T130323.635+0200 ERROR [SERVER] ce078b6a-3ba1-4329-a302-12a2d1d58af9 Command=Open connection;Result=-2146233079;ResultText=Error: Unable to connect to the remote server 0 0 0 INTERNAL sa_proxy 0 Not available Proxy Not available Not available Open connection -2146233079 Web exception when contacting service uri https://server.company.com:4900/ ce078b6a-3ba1-4329-a302-12a2d1d58af9

           

          Don't know if the text 'Unable to connect to the remote server' should be taken literally: it's actually all the same server, so this is a call to the port 4900 (BrokerService) on the same computer that fails.

           

          Erik

          • Re: ProxyErrorCode.1000 after installation of Qlik Sense September 2017
            Erik Wetterberg

            This seems to be a bug. After installation the directory \Program Files\Qlik\Sense\BrokerService\service-configs contains configuration of the services in json files. But there is also a package.json file. The Broker Service tries to parse all those files at startup and crasches:

            ERROR Exception: TypeError: Cannot read property 'forEach' of undefined

                at register (C:\Program Files\Qlik\Sense\BrokerService\utils\service-parser.js:230:28)

                at C:\Program Files\Qlik\Sense\BrokerService\index.js:134:45

                at Array.forEach (native)

                at create (C:\Program Files\Qlik\Sense\BrokerService\index.js:133:6)

                at processImmediate [as _immediateCallback] (timers.js:383:17)

            From previous event:

                at Object.<anonymous> (C:\Program Files\Qlik\Sense\BrokerService\index.js:170:99)

            After reamin the file (to package.jsonx) everything seems to work fine.

             

            Hope this helps somebody else

             

            Erik Wetterberg