1 Reply Latest reply: Oct 9, 2017 10:45 PM by Andrew Sumner RSS

    Upgrading from 2.2 to 3.2, error 403 on login using virtual proxy

    Andrew Sumner

      This was never an issue with 2.2, which is why we've kept using it. We tried upgrading to 3.0 when it was released, ran into this problem and couldn't find a solution hence we decided to wait hoping there'd be a fix - however the situation's changed and we're now forced to upgrade hence we need to find answers - any help you can provide would be greatly appreciated & hopefully assist others who may run into the same problem.

       

      If I login directly without a proxy its fine, the error only occurs when using the virtual proxy. The actual message is "Could not authenticate to Qlik Server. The remote server returned an error: (403) Forbidden."

       

      Our proxy setup is as follows:-

      virtual proxy setup.png

       

      We're using Forms authentication as our existing setup for multiple external customers is forms-based; changing it to Windows auth really isn't an option.


      We've tried removing/reinstalling the certificate, we've followed a bunch of suggestions from other threads on the forum here such as creating a new proxy, cleaning the database and re-running the installer in repair mode - all to no avail.


      I'm sure there's other things we could check, but our google-fu hasn't proved strong enough yet to find them. Your suggestions would be most welcome, and if there's any more info about our setup which would be helpful please let me know - I'd be happy to provide any information which may help get to the bottom of this.