3 Replies Latest reply: Oct 20, 2017 8:10 AM by Mike Hildner RSS

    Sept 2017 Release - SQL statements failing

    Mike Hildner

      After upgrading from June 2017 to September 2017, some of my SQL statements are failing. Running against Sql Server, I can see via the Profiler that too much of the script is being sent over the wire. That is, instead of just sending the sql up to the semicolon in the script, it includes script statements that follow the semicolon.

       

      The scripts have not changed and were working fine until the Sept 2017 upgrade. Anyone seem similar behavior?

       

      Thanks,

      Mike

        • Re: Sept 2017 Release - SQL statements failing
          Tamarah Carolus

          Hi Mike,

           

          Maybe it has something to do with the use of double quotes. I've not experienced it myself (yet), but a colleague of mine did.

           

          In previous versions of Qlik Sense the following statement worked like a charm:

           

          Test:

          LOAD field

          ;

          SQL SELECT field

          FROM Data.Pub."AA-01"

          ;

           

          But he had to change it to FROM "Data"."Pub"."AA-01" ; for it to work properly after upgrading to the September version.

           

          Maybe this works for you too.

            • Re: Sept 2017 Release - SQL statements failing
              Mike Hildner

              Thanks for the info Tamara. My situation is a bit different in that it's specific to calling a stored procedure. This is using a Sql Server OLE DB connection.

               

              Here's a simple script to duplicate:

               

              script.png

               

              That's the entire script.

               

              When I run that, I get an error message in Qlik

               

              Connector reply error: ErrorSource: Microsoft OLE DB Provider for SQL Server, ErrorMsg: Incorrect syntax near '/'.

               

              I can see via Sql Server Profiler that what's being sent includes more than my script:

               

              Profiler.png

               

              Interestingly, if I change @Param1 = N'18', things work fine:

               

              Profiler2.png

               

              Of course since that stored procedure does not exist, there's an error about that, but that's to be expected. The point is what is being sent to sql server is not always correct in that it includes too much of the Qlik script. This was working fine before the Sept 17 upgrade.

               

              Regards,

              Mike