4 Replies Latest reply: Nov 29, 2017 3:41 AM by Rohit Kumar RSS

    Load balancing not working

    Rohit Kumar

      Hi Techies,

       

      I have three servers, #1 which is central node, #2 which has N printing installed and #3 which is Balancing Node. I have one application #App which is Balanced or SYNC to #3 node or server and when i open this application it is consuming #3 resources.

       

      Now: When I am working on #2 which is N Priniting server and run a report through N printing and on the stage of REPORT GENERATION, the consumption of #1,#2,#3 are:

      #1(Central Node) has 30-35%

      #2(N printing server) has 1-8%

      #3(Balancing Node) has 1-8%,


      I am trying to know why report generation is consuming central node resources when #App sync to #3 Balancing Node ?


      Thanks in advance

      Rohit

        • Re: Load balancing not working
          Fábio Ribeiro

          Hi Rohit, how are you?

           

          Could you post what URL are you using in the NPrinting Connection?

            • Re: Load balancing not working
              Rohit Kumar

              Hi Fabio,

              Thanks for your response.

              There is two way of configuring the N Printing connection, First, I put Central node in Proxy address and second I put my load balancing Node address in it:

               

              If i put Central node address, it is far better than putting Load balancing Node address.

               

              I wana know in both of the way my why central node resources are getting consumed so high when I have sync to #3 Load balancing App(Proxy,Engine Services are enabled).

               

              I am attaching the snapshot of N printing connector

               

              Nprinting.png

                • Re: Load balancing not working
                  Fábio Ribeiro

                  I'm not 100% sure about how NPrinting works to get the information in Qlik Sense. But if you allow me some suggestions.

                   

                  Try this setting.

                   

                  Place the Scheduler only as Master on your central Node. The other nodes can only be Slaves. but you can turn off the Scheduler service on servers where you do not want to reload.

                   

                  Make sure you have placed all servers in the Proxy Load Balancer. Make sure you've set up the Whitelist on all Proxys.

                   

                  As a last option you can use the URL of the proxy on which you want to consume the information.

                   

                  Please let me Know if this informations help you.

                    • Re: Load balancing not working
                      Rohit Kumar

                      Hi fabio

                       

                       

                      Please find my comment below:

                       

                      I have 5 serves:

                      1 Central

                      2 Proxy nodes(engine+proxy)

                      2 scheduler Nodes(Engine_scehduler)

                       

                       

                      Place the Scheduler only as Master on your central Node. The other nodes can only be Slaves. but you can turn off the Scheduler service on servers where you do not want to reload.

                      My central node is settled to only master and reload servers are set to slaves. My proxy node which has engine and proxy services are seperate than reload nodes which has engine and scheduler.

                       

                      Make sure you have placed all servers in the Proxy Load Balancer.

                      My F5 load balancer set to send trafic to my Proxy nodes(engine +proxy services)

                       

                       

                      Make sure you've set up the Whitelist on all Proxys.

                      I believe my white list porxy has been configured propery that why my https:/my given name/hub open the hub properly

                       

                      As a last option you can use the URL of the proxy on which you want to consume the information.

                      If I am using proxy nodes(Engine+proxy services) in N printing, consumption of Central node resources are so much high even if I have SNYC my all apps to Proxy nodes(Engine+proxy services).

                      When I put central node adderess in N printing connector it is far better than putting Proxy nodes address.


                      Please add your inputs on my comments please


                      Best,

                      Rohit