3 Replies Latest reply: Nov 16, 2017 1:31 AM by Jehad Alayed RSS

    Section Access Problems

    Jehad Alayed

      Hello there,

       

      I have a problem using section access. So I have added everything in the QlikView document I have to link with my excel file to get the information needed to have access for the users.

       

      First problem is sometimes if ACCESS is specified as as USER in the excel file, it will refuse the whole access for the user. and if it is ADMIN, access is accepted.

       

      Second problem is that I have 4 columns in the excel, ACCESS, NTNAME, PASSWORD, COMPANYCODE

      and everything works just fine except the COMPANYCODE, I have no idea why.

       

      I have tried apps made my others as examples and they work fine but when I try to apply what I got from them, it does not work on my application.

        • Re: Section Access Problems
          Miguel Angel Baeyens de Arce

          When ACCESS is equal to ADMIN in the section access table, there are no restrictions for the user to open the file using QlikView Desktop, but there might be if user goes through AccessPoint. How are your users going to open QlikView documents?

           

          Consider section access as any other table, if the field COMPANYCODE contains values which are not in the fact data of your QlikView application data model, no user will be granted access. To use reduction fields, both the field names and values must match in the data model in order to provide access (to a reduced dataset). In other words: if the field COMPANYCODE does not exist in the application or it has values (or it is empty) for users specified as USER, then users will be locked out of the app.

           

          You may want to try first removing the "Strict Exclusion" check in the Document Properties and see what happens when different users open the application and once you are sure, enabling it.

            • Re: Section Access Problems
              Jehad Alayed

              - My users are going to open the QlikView Docs via AccessPoint.

               

              - I got your point if the field actually exist or actually does it match? COMPANYCODE exist and it matches (either the field name or the data) even when I do a reload in the Doc and in QMC they both succeed.

               

              - I tried that and it seems to be the same. I still cannot restrict the user to one company and other restrictions.

               

              Thanks Miguel

            • Re: Section Access Problems
              Peter Cammaert

              Or another way to check whether Section Access correctly ties into your data model is this:

               

              • Put the Section Access statement in comments (place two slashes in front of it)
              • Reload your document
              • Open your document in QV Desktop
              • Put the NTNAME field in a listbox on a sheet.
              • Select different NTNAME values and see what happens with the associations in your document. If there is anything wrong with them (which we are assuming if we take the symptoms you described into account)

               

              Another question: why does Section Access contain both an NTNAME and a PASSWORD field?