2 Replies Latest reply: Nov 14, 2017 3:22 PM by jean-marc lessi RSS

    Error when loading tables in Qlik Sense

    jean-marc lessi

      Hi,

      I'm new to Sense Desktop and begin to recreate QlikView Documents to QlikSense.

       

      I don't encounter any difficulty, except for some tables i have in my database :

       

      if i do that :

      LOAD "timestamp",

          Code,

          Nom,

          Fournisseur;

      SQL SELECT "timestamp",

          Code,

          Nom,

          Fournisseur

      FROM FL2Clovis.dbo."CARPENTIERE FRANCE$Assurance crédit";

      It is OK, no error :

       

      if i do that :

      LOAD "timestamp",

          "N° client",

          "Code assurance",

          "Date début",

          "Date fin",

          Montant,

          "N° contrat",

          "Bloqué",

          Cascadable,

          Doublon;

      SQL SELECT "timestamp",

          "N° client",

          "Code assurance",

          "Date début",

          "Date fin",

          Montant,

          "N° contrat",

          "Bloqué",

          Cascadable,

          Doublon

      FROM FL2Clovis.dbo."CARPENTIERE FRANCE$Assurance crédit orig (tmp)";

       

      I got this error :

      Connector reply error: SQL##f - SqlState: 37000, ErrorCode: 102, ErrorMsg: [Microsoft][SQL Server Native Client 11.0][SQL Server]Syntaxe incorrecte vers '/'.

      It happens for all tables which have an '('..')' in the name.

       

      This doesn't appear when i use QlikView.

      I cannot change the name because thess tables are ERP tables.

       

      Does anyone have an idea to solve this point ?

       

      Thanks,