2 Replies Latest reply: Dec 18, 2017 11:43 AM by Andrew Landry RSS

    NPrinting 'Interface not supported' error edit template

    Darrell Tobin

      Some of my NPrinting reports no longer open.

       

      I select the 'Edit template' button and the designer starts to load then a window pops up with message:

      'Interface not supported'.

       

      The designer app opens but you cannot see the objects in the left object section (it is totally blank).

       

      We have tried this on mutiple machines and the nprinting server and all are showing the same error on the report in question.

      If I open other report though these work correctly. 

        • Re: NPrinting 'Interface not supported' error edit template
          Ruggero Piccoli

          Hi Darrell,

           

          My suggestion is to try to reinstall Qlik NPrinting Designer. If this doesn't work, please open a support ticket because the issue is strange and needs a deeper investigation possible only via remote session.

           

          Best Regards,

          Ruggero

          ---------------------------------------------

          When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

          • Re: NPrinting 'Interface not supported' error edit template
            Andrew Landry

            The problem for me was that the previous version of Excel was uninstalled incorrectly on the machine. To fix it, I used the following instructions from Microsoft:

            1. Open the regedit editor.
            2. Open HKEY_CLASSES_ROOT >> TypeLib >> {00020813-0000-0000-C000-000000000046}  

              (The Excel PIA key is {00020813-0000-0000-C000-000000000046})

            3. Delete the last version folder (Excel 2013 is 1.8, Excel 2016 is 1.9)