6 Replies Latest reply: Aug 24, 2018 10:57 PM by rui zeng RSS

    ODBC User Directory Connectors

    Tim Jeanes

      Our primary data store is a Microsoft SQL Server Database. We've recently upgraded from SQL Server 2016 to SQL Server 2017 and we're having trouble linking Qlik Sense to the database.

       

      We have Qlik Sense (version 2.2 I think - where can I check this?) running on Windows Server 2012 R2. We store the database connection details in Windows' ODBC Data Sources on that server. I've updated the connection to point to the new database and Qlik is happy with this: the Reload task runs successfully.

       

      However, the User Directory Connector is less happy. It says:

      The User Directory Connector (UDC) is not configured, because the following error occurred: Error when validating tables: One or more of the expected tables QlikUser and QlikUserAttribute are not present

       

      Our settings look like this:

      ODBC UDC.png

      I am confident that the Connection String is correct, for the following reasons:

      • The main data load task uses the same connection (iPresentStaging, as defined in Windows' ODBC Data Sources), and this runs successfully.
      • If I change the password in the Connection String, I get a different error ("Exception when trying to connect to the data source. Edit the connection string in the user directory connector configuration").
      • I also get that different error if I change the user's password in the SQL database.

       

      QlikUser and QlikUserAttribute are Views in our database. They are operating normally (I can SELECT from them). They have no unusual permissions on them, so the database user called "Qlik" should be able to access them. Since it can do the main data load task, I don't think that's the issue. I've tried explicitly granting the database user access to them anyway, but that made no difference.

       

      I have tried making actual tables (rather than views) in our database, pointing the UDC at them. I still get the same error.

       

      I have restarted all the Qlik services to no avail.

       

      Are we aware of any changes between SQL Server 2016 and 2017 that might cause this issue? Is there anything more I can try to resolve this?

       

      Thanks.