2 Replies Latest reply: Jan 8, 2018 10:25 PM by Jim Shi RSS

    which version of installshield did Product team use for IE Plugin ?

    Daniel Seo

      My customer has an installing issue with IE Plugin and QlikView desktop.

      The customer needs to distribute IE Plugin to a lot of new clients in their company .


      But they can not install IE Plugin on all client machines

      They tried installing IE Plugin on the clinet machines (All of from 11.20 SR 13 to 12.10 or later version) with all solution from SFDC and Google but it do net work


      So, the customer has built their own installer (IE Plugin) themselves using Installshield version 23.0 511

      (The installer of IE Plugin has been built from partner's PC that IE Plugin has already been existed )

      As a result, they can install IE Plugin on the client laptops using their own Installer. 


      So, the cutomer asked for the follwoining questions Q

        1. Which version of Installhied did Product team use to build IE Plugin ?

        2. Does Product team re-build IE Plugin using higher version or Installshield ( 23.0 511 or latest version ) for the customer ?


      Customer environemnet

      - Microsoft Windows 7 Standalone Workstation

      - Test it on QlikView from 11.20 SR 12 to 12.20)



        • Re: which version of installshield did Product team use for IE Plugin ?
          Peter Cammaert

          I cannot help you with this, as it is more of a question for Qlik R&D. And I sincerely hope that those people have time to read the Community and answer your question.


          However, I think that you - being a Qlik employee yourself - may have better internal channels at your disposal to ask this kind of question.

          • Re: which version of installshield did Product team use for IE Plugin ?
            Jim Shi

            The Windows installer was recently upgraded

            [from]   Installshield 2011

            [to] Installshield 2016

            for Qlikview builds from git branches master (Build #966) and release/QV12-20 (Build #26) and development branches originated from those.

            The upgrade resulted in a changed behavior when installing/uninstalling QlikView*.exe from command line.


            Installshield 2011

            A Setup.exe launcher created by a Basic MSI or InstallScript MSI project waited for the Setup.exe process to complete before return control.


            Installshield 2016

            1. Setup.exe launcher created from a Basic MSI or InstallScript MSI is intended to use the /clone_wait command line parameter to properly wait on the installation.


            What the above means is that launchers created with Installshield 2016 will not wait for the installation process before returning the control and this can be troublesome

            in some scenarios such as batch files where you might have sequential commands dependent on each other.

            1. e.g.        Command 1 installs the Qlikview product

            Command 2 starts a service that was installed in Command 1


            For the Command 2 to be successful, the Qlikview product needs to be installed.

            With Installshield 2011: this will work out of the box i.e. Command 2 will not run until the Qlikview product is installed.


            With Installshield 2016 and the exact same command as above: Command 1 runs (Installation is started) and then Command 2 runs directly after thus

            Command 2 starts to run during the Qlikview product installation and not after.


            There is a remedy for the new behavior. Below you can see examples of updates needed (in red) in two common installation scenarios:



            Installshield 2011

            QlikViewServer_x64Setup.exe /s /v" /qn ADDLOCAL="ALL" IS_NET_API_LOGON_USERNAME="<user> " IS_NET_API_LOGON_PASSWORD="<pwd>""


            Installshield 2016

            START /WAIT “” QlikViewServer_x64Setup.exe /s /v" /qn ADDLOCAL="ALL" IS_NET_API_LOGON_USERNAME="<user>" IS_NET_API_LOGON_PASSWORD="<pwd>"" /clone_wait


            1. Psecex.exe

            Installshield 2011

            1. psexec.exe -accepteula <computer> -h -u <user> -p <pwd> -w <path> <path>\QlikViewServer_x64Setup.exe /s /v"/qn ADDLOCAL="ALL" DEFAULTWEBSITE="1" IS_NET_API_LOGON_USERNAME="<user> " IS_NET_API_LOGON_PASSWORD="<pwd>""


            Installshield 2016

            1. psexec.exe -accepteula <computer> -h -u <user> -p <pwd> -w <path>  <path>\QlikViewServer_x64Setup.exe /s /v"/qn ADDLOCAL="ALL" DEFAULTWEBSITE="1" IS_NET_API_LOGON_USERNAME="<user>" IS_NET_API_LOGON_PASSWORD="<pwd>"" /clone_wait