5 Replies Latest reply: Jan 25, 2018 2:23 PM by Steve Wallace RSS

    IndexAdd error

    Steve Wallace

      I'm receiving the following error when trying to use IndexAdd. I am thinking it needs a direct path instead of relative? What's the proper way to implement that? A full path in the indexAdd arguments?

       

      Here's my error and script

       

      Script:

       

      Comment Table Member_Coverage with 'CIN,MemberCoverage,MemberDetails';

       

      Store Member_Coverage into [$(vG.LoadPath)\Member_Coverage.QVD] (qvd);

      Call IndexAdd('$(vG.LoadPath)\Member_Coverage.qvd');

      Drop Table Member_Coverage;

       

      Error:

      The following error occurred:

      No qualified path for file: ***

      The error occurred here:

      store * from [___vL.tmpTable] into 'Index\OHG_1.QVD_3.Load_Member_Coverage.QVD.Index' (txt,delimiter is ';' )

        • Re: IndexAdd error
          Anil Samineni

          Have you call this IndexAdd directory to any SUB routine somewhere. Can you show the image how path indicates

          • Re: IndexAdd error
            Magnus Berg

            Hi Steve, IndexAdd need to store the created index under the shared container. Please validate that you have a Shared container available. Validate that you have a relevant vG.SharedConfigPath variable, this where the index is stored, under a folder named Index.

            Regards

            Magnus

              • Re: IndexAdd error
                Steve Wallace

                note: This is all in qliksense enterprise

                 

                I had included LCGV('Shared') in the initialization part of my script but I'm noticing now that there is an error in the read out that says 'vG.SharedBasePath not found' which is, I'm guessing the reason index can't find its proper directory.

                 

                I'm guessing it's because I ended up having to call 'SET vG.HomeContainer='lib://Root\20.CIN';' in order to get it to find the InitLink.qvs script? I had originally wanted to set it up as single lib mount, Root points to the base directory where all the containers are but for whatever reason it would fail anytime I tried to call InitLink.qvs until I set the HomeContainer variable....


                Steve

                  • Re: IndexAdd error
                    Magnus Berg

                    Hi Steve, if you are using separate lib mounts you need to create a lib connection named Shared pointing to the shared container.  If you have problems please send me your containermap.csv and the InitLink.qvs initiation, I will set it up myself and give you hints.

                    regards

                    Magnus

                      • Re: IndexAdd error
                        Steve Wallace

                        I added the shared lib and it started working. It's interesting, I don't seem to be able to get single lib working in Qliksense, it always prompts me to provide vG.homecontainer in order to load the init script and subsequently swaps to multi lib. It's working with multi lib though and that's perfectly acceptable.

                         

                        Thanks,

                        Steve