1 Reply Latest reply: Aug 15, 2018 2:22 AM by Prasadini Ariyaratne RSS

    Odd Behaviour - Section Access in Qlik Sense

    Cameron Scott

      I have been playing around with Section Access in Qlik Sense (both v3.2 and vSeptember 2017). I have been banging my head against the wall with one recurring issue. I could never get section access to work for my account.

       

      This was my setup. In my test I had two users (myself and a testing user). I was managing section access with an external data set (rather than inline code). This data set (excel file) had two sheets; one with the section access rules and one with mock data. So I would run the data load and check what data was accessible to both myself and the testing user. Every time the section access rules would only be applied to the testing user while myself still had full data access.

       

      So I had to put on my troubleshooting hat and get digging. I read a bunch of stuff and tried a bunch of stuff to no avail. Then I decided to try the reverse of what I had been doing and have the testing user run the data load. And wouldn't you know it the outcome flipped! Now the testing user had full access while myself was restricted based on the section access rules. So I decided to try configuring a task to load the data. After running that task BOTH myself and the testing user had the section access rules properly applied.

       

      Now I have no idea why this is the case but after multiple tests the results are consistent. I just wanted to write this out in case anyone else is struggling with the same issue. And if anyone can explain why this is the case that would be great to know.

       

      -Cam