5 Replies Latest reply: Feb 6, 2018 2:58 PM by Nathan Bethea RSS

    NullAsValue replaces null values on one Field, but not the other

    Nathan Bethea

      For example

       

      I have a field with null values that I want to replace with a string. When referencing a field from Table A, the script works as expected and replaces all null values in 'MyWorkingField' on Table A. However, I realized "MyWorkingField" from Table A will not work. Instead I need to use "MyBrokenField" from Table B, however when replacing "MyWorkingField" with "MyBrokenField" the script does not work.

       

      Set NullValue="Hello";

      NullAsValue MyWorkingField;           // this is from Table A and works as expected

       

      Set NullValue="Hello";

      NullAsValue MyBrokenField;             // this is from Table B and does not work.

       

      Initially I put this script at the bottom of the "Main" sheet in the Data Load Editor and it worked fine with 'MyWorkingField', this did not work for "MyBrokenField". I have tried putting the same script for "MyBrokenField" in the Auto-Generated section under the corresponding table only to get the same result.

       

      Any help would be greatly appreciated as I have poured over the forums to find an answer and this is really frustrating.