3 Replies Latest reply: Feb 7, 2018 4:07 AM by Ruggero Piccoli RSS

    Nprinting Cycle Not Cycling

    Erik Anderson

      I recently upgraded to 16.7 and Qlikview 12.10 and one of my reports no longer cycles constantly.  It will work fine 20% of the time.  However, the rest of the time it will not apply the filter as it cycles through.  Resulting in all the reports being the same. I can of course make a report and apply the filter to each one, but I would rather it just worked as it has for the past 2 years. It is a linked field if that makes a difference.

       

      Any thoughts?

        • Re: Nprinting Cycle Not Cycling
          Ruggero Piccoli

          Hi Erik,

           

          The Qlik NPrinting 16.7 version has no changes in the cycles code so we need to investigate.

          Could you check and share the logs?

          What SR of QlikView are you using?

          What versions of Qlik NPrinting and QlikView you used before?

          Could you test with NPrinting 16.7 and the previous version of QlikView? And vice-versa (QlikView 12.10 and previous version of Qlik NPrinting)?

           

           

          Best Regards,

          Ruggero

          ---------------------------------------------

          When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

            • Re: Nprinting Cycle Not Cycling
              Erik Anderson

              Here is a log from a failed attempt.

              I am using Qlik 12.10.20600.0 SR8

              Previously we were on Qlik 11 and Nprinting 16 (older version) don't remember.  I can ask the admins if you need specifics.

              We have rolled back both Nprinting and Qlik together and individually to no avail. 

               

              Thanks for your efforts.

                • Re: Nprinting Cycle Not Cycling
                  Ruggero Piccoli

                  Thanks for the log, we checked it with the help of a Qlik NPrinting 16 developer.

                   

                  The log shows a first run that was manually stopped and a second run who produces 7 reports with no errors. Based on logs object filters were applied at every step of the cycle.

                   

                  In my opinion you should check the filters you applied to the objects. Maybe you need to apply the Verify filter flag.

                   

                  If this doesn't work please open a support task so you can do a deeper investigation with the help of a support person.

                   

                   

                  Best Regards,

                  Ruggero

                  ---------------------------------------------

                  When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.