2 Replies Latest reply: Feb 14, 2018 12:25 PM by David Vasseur RSS

    proxyRestUri and proxied QS server

    David Vasseur

      I'm playing with external authentication (Google SSO) and noticed that the proxyRestUri il always using the real server hostname, Not the one I've used in my connection URL. Could be annoying because my QS server is proxied through nginx...

       

      For example:

      _https://nginx/google <- link to QS virtual proxy 'google'

      redirects me to:

      _https://qlik-auth/?proxyRestUri=https%3a%2f%2fsrv-vm-qs%3a4243%2fqps%2fgoogle%2f&targetId=0d7b5f6a-b0f5-4721-886c-daf011d798c2

       

      the proxyRestUri should be "proxyRestUri=https%3a%2f%2fnginx%3a4243%2fqps%2fgoogle%2f&targetId=0d7b5f6a-b0f5-4721-886c-daf011d798c2" instead of "srv-vm-qs" which is my real server name

       

      Any idea to fix this ? I couldn't find any option for this in the QMC