3 Replies Latest reply: Feb 28, 2018 3:33 AM by Tim Driller RSS

    OMIT Problem

    Tim Driller

      Hello,

       

      i have encountered a weird behavior in Section Access with OMIT field.

      Im using QlikView 11.

       

      Document Settings:

       

      Szenario 1) Script)

      OMITgroup in Inline Table: This works fine

       

       

      Section Access;

      OMITGROUP:
      Load * inline [
      OMITGROUP, OMIT
      Group1, Field1
      Group1, Field2
      Group1, Field3
      Group1, Field4
      ]
      ;

      OMIT:
      load * inline [
      ACCESS, NTNAME, OMITGROUP
      ADMIN, DOMAIN\USER, 
      USER, DOMAIN\USER1, Group1
      ]
      ;

      Section Application;
      Star is *;

       

      Szenario 1) Ouput)

      works as expected. Fields are not available

       

       

       

      Szenario 2)

       

      Add Users with Omitgroup via concatenate Load. This doesn't work

       

       

       

       

      Section Access;

      OMITGROUP:
      Load * inline [
      OMITGROUP, OMIT
      Group1, Field1
      Group1, Field2
      Group1, Field3
      Group1, Field4
      ]
      ;

      OMIT:
      load * inline [
      ACCESS, NTNAME, OMITGROUP
      ADMIN, DOMAIN\USER, 
      ]
      ;

      Concatenate (OMIT)
      LOAD 'USER' as ACCESS,
      'DOMAIN\USER1' as NTNAME,
      'Group1' as OMITGROUP
        
      AutoGenerate (1);

       

       

      Section Application;
      Star is *;

       

       

      Szenario 2) Output)

       

      Omit doesnt work

       

       

       

       

       

      Can anyone explain me why this happens?

       

       

       

       

      Regards

      tim