1 Reply Latest reply: Mar 22, 2018 7:08 PM by Jason Holderness RSS

    Qlik Sense: An error occurred.The app has been closed.

    Jason Holderness

      Hi all,

       

      We have a locally installed version of Qlik Server. I've recently started encountering an issue in Qlik Sense when in an app. After a short time of no click activity, Qlik pops up a dialog box with "An error occurred" title and the message "The app has been closed. To continue working, please refresh the app." Then it gives the option to refresh, or go to the hub. Screenshot of pop-up attached.

       

      When this happens, I'm seeing a whole bunch of errors pop up in the browser debug console. They must be timed based, because a new crop of them flow through the console every couple of seconds. The javascript error is:

       

      TypeError: Cannot read property 'id' of undefined

       

      The error references require.js and client.js. Screenshot of errors attached.

       

      I'm using the latest version of Google Chrome for Mac (65.0.3325.146). I've tried restarting the browser and my computer. I've cleared my browser cache and done a hard refresh of the app page in QlikSense. No dice.

       

      I also tried this in Apple Safari browser (11.0.1 (11604.3.5.1.1)), and had the same thing happen. So it may not be a browser issue.

       

      I also noticed this is only happening in the app view, and not the hub.

       

      I tried searching the forum for this error, but the post I found didn't seem to have a clear solution that would apply to me. Any help would be greatly appreciated.