4 Replies Latest reply: Mar 21, 2018 11:49 AM by Alessandro Furtado RSS

    AGGR Não mostra resultado em todas a linhas

    João Candido

      Bom Dia, podemos ver na imagem abaixo existe uma coluna % essa coluna mostra o o percentual que representa cada linha comparado ao valor total do grupo, para isso estou utilizando a seguinte fórmula.

      SUM(VALOR)/SUM(AGGR(SUM(VALOR), GRUPO, SITIO, ANOMES))

      porém, como podemos notar a fórmula só esta mostrando resultado em algumas linhas e entendo que deveria mostrar em mais linhas, já utilizei essa fórmula outras vezes, não consegui identificar o que esta acontecendo.

      Como poderia resolver essa questão?

      Essa é a melhor maneira de calcular essas situações?

      Percentual.PNG

        • Re: AGGR Não mostra resultado em todas a linhas
          Sunny Talwar

          May be this

           

          SUM(VALOR)/SUM(AGGR(nodistinct SUM(VALOR), GRUPO, SITIO, ANOMES))

          • Re: AGGR Não mostra resultado em todas a linhas
            João Candido

            Ainda sobre esse caso, podemos na imagem abaixo que o valor calculado pela fórmula

            SUM(AGGR(SUM(VALOR), GRUPO, SITIO, ANOMES)) esta correto, porém não esta sendo exibido em todas as linhas

            Soma em uma linha.PNG

            No gráfico temos

            Conta DRE                               Valor                       %

            Venda de Suinos Bloco               8.271                            0

            Venda de Suinos NFs          1.610.913              1.619.184

             

            O valor de 1.619.184 é a soma dos dois valores da coluna valor, mas só esta sendo mostrado e uma linha, com isso não consigo realizar a conta de percentual que seria

            Conta DRE                               Valor                       %

            Venda de Suinos Bloco               8.271                      8.271 / 1.619.184) =   0,51%

            Venda de Suinos NFs          1.610.913              (1.610.913 / 1.619.184) = 99,49%

             

            Inicialmente pensei que pudesse ser esse parâmetro, mas já tentei marcar e desmarcar, de nenhuma forma deu certo.

            Parametro.PNG

            Qual seria a solução para essa questão?

            Não sei se isso é relevante, estou usando a versão February 2018.