4 Replies Latest reply: Apr 16, 2018 5:43 AM by Ismael Chinea RSS

    Engine API Explorer: CreateBookmark - Invalid

    Ismael Chinea

      I'm trying to create a bookmark following the instructions given in the Qlik Sense documentation, but it shows an 'invalid' message (please, see pic below). I've read and tried everything but I cannot see the bookmark on my app.

      Untitled.png

      I'm using Qlik Sense June 2017.

      Could somebody suggest what I'm missing here?

      Thanks a lot.

        • Re: Engine API Explorer: CreateBookmark - Invalid
          Erik Wetterberg

          Hi,

          The Invalid text means that the data for that object has been invalidated, so probably you have actually created a bookmark. Great calling getLayout or getAppLayout for the objects and they will be valid again.

           

          Erik Wetterberg

            • Re: Engine API Explorer: CreateBookmark - Invalid
              Ismael Chinea

              Thanks for your help!

              If I call getBookmarks I can see a list with all BM I've created, however, if I go the app I cannot see them.

              Also, after calling getLayout the bookmark change to 'Valid' but it doesn't appear yet in the app.

               

              I'm probably missing some basic step in the process...

                • Re: Engine API Explorer: CreateBookmark - Invalid
                  Erik Wetterberg

                  Hi,

                  Probably the client needs some property that you have not set. Try checking what properties are set on bookmarks that are visible in the client.

                   

                  Erik Wetterberg

                    • Re: Engine API Explorer: CreateBookmark - Invalid
                      Ismael Chinea

                      Thanks again, it fixed the issue!

                      Just in case it helps to somebody else, I did the following:

                      • I created one bookmark manually on the app
                      • From the Engine API I called "GetLayout" on the bookmark I created and checked its properties
                      • I found there were two parameters I didn't specified: "sheetId", "creationDate"
                        • "creationDate" is optional
                      • Also noticed that "qType" must be 'bookmark' in lower case
                      • I included them and now my bookmark shows up in my app

                       

                      Request:

                      {

                          "handle": 1,

                          "method": "CreateBookmark",

                          "params": {

                              "qProp": {

                                  "qInfo": {

                                      "qId": "bm01",

                                      "qType": "bookmark"

                                  },

                                  "qMetaDef": {

                                      "title": "Test",

                                      "description": ""           

                                  },

                                  "sheetId": "l9h38ud1-62c8-3264-89m6-c3f15de2e20a"

                              }

                          }

                      }