1 Reply Latest reply: Apr 17, 2018 3:17 PM by Petter Skjolden RSS

    Unable to connect-Qliksense to Local MS SQL

    ishan das

      I'm trying to fetch data from my local MS sql server and put it on Qliksense (on web, enterprise edition) via data load editor. But no go,


      Attempted to create a new connection using OLE DB,

      used provider "MS OLE DB provider for MS SQL",

      data source as "Local Server Name"....test fails...

      have tried windows integrated security as well as specific user name and password options.


      is it possible to connect Qliksense on web to local MS SQL(desktop) ?

        • Re: Unable to connect-Qliksense to Local MS SQL
          Petter Skjolden

          Yes definitely.


          Did you try with only a single period - a dot as the Data Source? MSSQLSERVER is often the default name.


          Did the MS SQL Server install as a named instance? Then the instance would have to be specified as <servername>\<instancename> or (local)\<instancename> or .\<instancename>


          Here is a SQL script you can run in Microsoft SQL Server Managment Studio to determine some of this information:


          set nocount on
          Declare @key Varchar(100), @PortNumber varchar(20)

          if charindex('\',CONVERT(char(20), SERVERPROPERTY('servername')),0) <>0 begin
            set @key = '
          SOFTWARE\MICROSOFT\Microsoft SQL Server\'+@@servicename+'\MSSQLServer\Supersocketnetlib\TCP'
          end else begin
            set @key = '

          EXEC master..xp_regread @rootkey = '
          HKEY_LOCAL_MACHINE', @key = @key,
            @value_name = '
          Tcpport', @value = @PortNumber OUTPUT
          servername')) ServerName,
            CONVERT(char(20), SERVERPROPERTY('
          InstanceName')) InstanceName,
            CONVERT(char(20), SERVERPROPERTY('
          MachineName')) as HostName,
          convert(varchar(10), @PortNumber) PortNumber

          origin of script: How do I connect to the default instance of SQL Server if a "named instance" parameter is required? - Stack Overflow