7 Replies Latest reply: Nov 24, 2013 1:05 PM by David Kusek RSS

    Different Results between Server Load and Manual Load

      Hello - I am having an issue with a simple SQL query that when I run in SQL I get a single result.  When I run the same query in QlikView with a manual load I get the same single result.  But when I run the same application from the Management Console server side I get multiple results for the same query.  I have tried rewriting the script multiple ways to accommodate for text vs num etc but still get the same results.  One of the fields in question contains a "dash" ( - ) and this is what I believe is causing the issue but not able to correct it with server side load.

       

       

      ItemDescription
      11007E-0022Item # 1
      11007E-0174Item # 2
      11007E-0914Item # 3
      11007E-0924Item # 4

       

       

      When I manually load and I drill to 11007E-0914 I get the description of "Item # 3".  (Correct)

       

      When I server side run the application and then drill to the same Item I get all 4 descriptions. 

       

      I am running Server 9.0 SR4.

       

      Has anyone had any kind of similar issues with Server Side results being different than manual loads?  Any help would be greatly appreciated.

       

      Thanks!