3 Replies Latest reply: May 28, 2018 7:40 AM by Kirill Golovanov RSS

    OneDrive and QS desktop; The engine could not be unlocked. Please retry.

    Onno van Knotsenburg

      I can't get Qlik Sense desktop to work (stable) on my laptop.

       

      I've been around since day one of Qlik Sense desktop. I installed it probably a hundred times by now and never had any problems.

      ... till now...

       

      My current assumption is that OneDrive "kills" Qlik Sense desktop. I like to get that confirmed or disproven.

       

      Here is what I did:

      • I have installed February 2018 on my new laptop. Worked.
      • Restarted it a week later: Failed to work, giving me a popup with "The engine could not be unlocked. Please retry.".
      • De-installed. Installed again. Still failed to work.
      • De-installed, rebooted laptop, installed again. Still failed to work.
      • De-installed, deleted all related folders left behind, installed again. Still failed to work.
      • De-installed, de-installed IIS (hoping that portal stuff might be causing the problem), [repeat previous steps]. Still failed to work.
      • Gave up.
      • Today tried again, but this time installed April 2018. Low and behold; it worked!
      • Copied a bunch of my apps back, hit "refresh", and they all showed up.
      • ... so... Now it feels like the problem is solved. Till I closed QS, restarted... and the problem is back. Failed to work giving the popup mentioned earlier.
      • Closed QS, deleted the whole Qlik folder in "my documents", restarted... works again. Lowsy, but okay. QS created the Qlik folder again.
      • Didn't do anything (so no apps), closed QS, restarted... failed to work.
      • Closed QS, deleted Qlik folder, paused OneDrive from syncing, restarted QS... worked.
      • Kept OneDrive paused, closed QS, copied my examples back in, restarted QS... still works!
      • Closed QS, unpaused OneDrive, waited a few minutes till it is 100% synced, start QS... aaaaaaaaand it is broken again.

       

      Questions:

      • Does anyone else have problems with QS Desktop in combination with OneDrive?
      • Can anyone confirm that OneDrive is indeed causing this problem (as I am not 100% sure yet, thought can't figure out what else might cause my problem)?
      • Did you solve it? How?

      ... and yes... so far it seems "just not use OneDrive" is the solution, but that is kinda hard when it is company standard.