1 Reply Latest reply: Jun 27, 2018 7:04 AM by andy whitfield RSS

    April 2018 - is this a bug?

    andy whitfield

      We've had this reported by one of our clients:

       

      I've installed the Qliksense April release on our dev server and have done some testing.  This has shown a strange behaviour when running invalid sql statements.

       

      As an example - if I run the following query against our Postgres database I immediately get a syntax error (syntax error at or near "[") as the square brackets aren't valid in postgres:

      select count(*) as [Total]

      from bimis.bill.execs;

       

      If I include the below statement in a script running in an app on our dev Qliksense server (Qliksense April 2018) running against the same db, it doesn't error but it never returns any data. It appears to be stuck on the loading window remains open with the in-progress icon circling.

      [Temp]:

      load *;

      sql select count(*) as [Total]

      from bimis.bill.execs;

       

      However if I run the above statement on our prod Qliksense server (Qliksense Feb 2018), I get an immediate error.

       

      Is this a known issue?  If so, are there any available fixes or workarounds?

       

      Any ideas?

       

      BR

       

      Andy