4 Replies Latest reply: Jul 17, 2018 5:42 PM by David B. RSS

    Issue in data after transform

    Cyrille Leja

      Hello,

       

      this is my issue, i make a mapping to transform numeric field in a string :

       

       

      Issue1.jpg

       

       

      I save and reload data, but in my dashboard i still have numéric value like below  :

       

      Issue2.jpg

       

       

       

      could you please help ?

       

      regards,

       

      Cyrille

        • Re: Issue in data after transform
          David B.

          Hi,

          To force the format of your data, in the load statement you can make a :

          text([your field]) as your_field_name

           

          It should be considered as a text format.

            • Re: Issue in data after transform
              Cyrille Leja

              Hello David,

               

              thanks I have this :

               

              :

              MAPPING LOAD * INLINE[environmentMapping-FROM,environmentMapping-TO

              bpce,BPACAca,CAPCA];[bank_numberMapping]:MAPPING LOAD * INLINE[

              bank_numberMapping-FROM,bank_numberMapping-TO13507,BPN18707,BPVF17515,CEIDF

              13825,CERA11315,CEPAC18315,CECAZ12135,CEBFC10207,BPRI14707,BPALC14607,BPMED

              ];[shop]:

               

              How i can proceed ?

               

              thanks a lot

               

              Cyrille

               

              2018-07-11 0:15 GMT+02:00 David B. <qcwebmaster@qlikview.com>:

               

               

               

              • Re: Issue in data after transform
                Cyrille Leja

                I have tried this :

                 

                APPLYMAP( 'bank_numberMapping', text()) AS

                ,

                 

                but still doesn't work

                  • Re: Issue in data after transform
                    David B.

                    Hi Cyrille,

                     

                    I think your mapping table should look like that :

                     

                    MAPPING

                    [bank_numberMapping]:

                    LOAD * INLINE [

                    bank_numberMapping-FROM, bank_numberMapping-TO

                    13507,BPN

                    18707,BPVF

                    17515,CEIDF

                    13825,CERA

                    11315,CEPAC

                    18315,CECAZ

                    12135,CEBFC

                    10207,BPRI

                    14707,BPALC

                    14607,BPMED

                    ]

                    ;

                     

                    Then,

                    ApplyMap('bank_numberMapping', [field name you want to map with bank_numberMapping-FROM], 'default value whe if needed') as [bank_numberMapping-TO]

                     

                    Be carefull with '-' sign in your field names. It could considered as an operator. Use brackets [] to avoid it, or dont use them.


                    Let's try

                    bye