2 Replies Latest reply: Jul 14, 2011 5:15 PM by Andrew Pettit RSS

    GetTicketing and Enable Anonymous

      So I have GetTicketing setup and working in a test environment.  However I can only get the test htm file working as long as the directory containing the file uses Windows Authentication but this doesn't really work well for Session CALs where anonymous may be prefered.  What setting or permissions need to be applied to allow disabling Windows Authentication and enabling Anonymous on the QvAjaxZfc virtual directory in IIS7.  I've already tired setting the Anonymous account to the Application Pool account which is in the IIS_IUSRS, Administrators, and QlikView Administrators local groups.  What else am I missing???

        • GetTicketing and Enable Anonymous

          Why do you want access to the QvAjaxZfc directory? If you want anonymous access to the document, add the anonymous user access in QEMC; no tickets are needed.

           

          If you wan anonymous access to obtain a ticket, then that means everyone will have access to every document. Unless if there are other security measures, this seems like a huge risk. But if you still want to have anonymous access then you can write a wrapper aspx that will authenticate with hardcoded credentials and return the ticket.

            • GetTicketing and Enable Anonymous

              Its not the entire QvAjaxZfc directory I want anonymous access to, only the GetTicket test page.  For now I have moved it out to a new folder on its own.  Basically what I am trying to acheive is to get a ticket from an Anonymous windows account, that has been authenticated from another source like a portal site.

               

              So from the above I have set QvAjaxZfc back to Window Authenication, and put the get ticketing test page in a folder by it self with only Anonymous enabled, I also set the Anonymous account to be the service account for QlikView which is in the QlikView administrators group.

               

              The error I believe was in the portal pages and everything appears to be working now.