3 Replies Latest reply: Jul 22, 2011 8:41 AM by Daniel Rozental RSS

    Using QMS API with asp.net

      Hi,

       

      I have been trying to build an asp page that can use the QMS API in the same fashoin that the sample apps do. However I seem to have an issue, I have built a page using the sample code (adjusting where neccessary for current proj ref) and updated the Service reference etc... I

       

      I seem to be getting the "Service Key is Missing" error, expect that I am actually getting the service key abd can output this to the web page, but when the next piece of code executes, i.e GetServices(ServiceType) etc it throws the error.

       

      Have I missed something when using asp.net for the service key? I've checked the web.config and copied across all the relevant xml for the endpoints etc...

       

      Any thoughts?

       

      Thanks

      James

        • Using QMS API with asp.net
          Daniel Rozental

          Someone who had this problem mentioned recently to me that there was an extra space in the web.config/app.config file somewhere.

           

          Try posting your web.config file.

            • Using QMS API with asp.net

              Yes, that seems to be the general consensus, but what I find wierd is this:

               

              I have a Windows c# Forms app, that runs a simple connection to the API and retrieves a lits of documents.

               

              Everything works ok, so the app.config file clearly works. If I then port all the code over to an ASP.net application, copy the config xml over as is, it doesn't work and I get the service key issue?

               

              I'm wondering whether the config file needs to be changed for asp apps, but there's nothing in the QV documentation about using asp applications to give an example.

               

              Has anyone managed to get an asp.net app to work ok?