2 Replies Latest reply: Sep 5, 2011 5:17 AM by Sri Priya RSS

    Activex component can't create object:'ADODB' connection

    Sri Priya

      Hi

      Am using QV10 desktop and while trying to run a macro, am stuck up at this error: Activex component can't create object: 'ADODB connection'

      The same code when run in my colleague's PC, its working fine.

      We are new to Qlikview and could'nt figure out why this is happenning. Any DB connection Settings needs to be changed?

      Can anyone help with this?

       

      Am using QV10 and my colleague is using QV9.

       

      Thanks,

      Priya

        • Activex component can't create object:'ADODB' connection
          Daniel Rozental

          You need to give the macro access to the system. Try ctrl+shift+m with the application open to change security settings.

            • Activex component can't create object:'ADODB' connection
              Sri Priya

              Hi

               

              Thanks a lot for your reply:) Sorry for the late reply, System access is already given to the macros.

              I have searched a lot and got some information

               

              The problem is something regarding a .dll file not being registered with the system registry.

               

              When this issue is looked into, I have successfully registered the .dll file and now the error am getting is different. It says "Provider cannot be found. It may not be properly installed. " 

               

               

              It is a clear message that DB provider is not properly installed. But I can reload the QV file connecting to the same DB and in this case the connection to the DB is working fine and now I really couldn't figure out what the problem is

              Can anyone look into this please..

              Thanks,

              Priya