2 Replies Latest reply: Oct 11, 2011 2:45 PM by Knut Einar Reppen RSS

    People Gauge changing value problem

    Knut Einar Reppen

      I’m trying to implement the People Gauge in a models but I’m notable to edit the value.

      What I do(Qlikview Desktop 10 SR 1, MSIE 8, Windows XP):

      1. Installed the qar file etc. The chart works fine in the demo provided byQlikview. I can also enter date in the “Value:” field and when I leave thefield the graph is updated. I can also use copy and paste in the field.
      2. Then I open the model I'm working on.
      3. Enter the webview
      4. Add new object by selecting People Gauge
      5. Then right qlick and choose properties. If I then try to add something in the “Value:” and leaves the field, the field is empty again. If I try copyand paste nothing happens. But If I go to Caption and changes the label the object is updated.
      6. Then I tried to upgrade to SR2, since the Qlikview server has this Release. If I repeat the steps above same thing happens again.
      7. The I decided to verify this on my own laptop(Qlikview Desktop 10 SR3,MSIE 9, Windows 7) and repeat the same steps with the same result.
      8. I even tested on Qlikview 11 beta. Here I also created a new document. And tried to enter a new People Gauge there. But got the same problem with the value field.

       

      If I open the Extension demo it works OK on all machines/versions. ThereI can change the content of the “Value:” field.

      Conclusion:

      * Same error happens on different Qlikview versions, Windows versions and MSIE versions

      * Since it also happens on a new document it's not a problem with only one model

       

      Is there a document setting I don’t know of? Or other things that canExplain this strange behavior?

       

      Anyone else experienced this?

      Thanks in advance

       

      Best Regards

      Knut Einar

        • Re: People Gauge changing value problem
          Brian Munz

          Hi,

          Sorry I'm just seeing this now.  Somewhere along the line I think something changed in QV that caused this to break, but whenever it was or whatever the reason, I have a fix.

          In the Definition.xml file inside the folder for the PeopleGauge extension, there is a line like this:

          <Value Initial="" Expression="=0.7"/>

          Not sure why this was coded this way before but it should be changed to:

          <Text Initial="" Expression="=0.7"/>

           

          So, just in case you're not as familiar with editing extensions, I've attached a copy of the PeopleGauge qar that will work properly.  Just remove the extension from your model, go to wherever the extension is installed, remove it, then use the attached QAR.  If you're wondering where to find the extenstions, please see Dan English's comments at the bottom of this thread:

          http://community.qlik.com/thread/28944

           

          Let me know if it works!

            • People Gauge changing value problem
              Knut Einar Reppen

              Hi

               

              Thank you very much. I tried editing the Extension myself and it worked locally for me.

              I will test with my customers setup also, but expect it to work there too.

               

              I have been in contact with support also earlier, which has registrated it as a bug. So it will be fixed with future releases also. Meanwhile I hope people will find this Thread and either adjust manually themselves or use your qar file.