2 Replies Latest reply: Sep 22, 2011 2:56 AM by Anders Marklund RSS

    having problem with multipel rows in table

      Hi, having problem with multipel rows.

       

      For some reason, multiple rows are present in one of the straight tables. I am loading data fom several excelfiles. When reading data from a specifik file the data is assigned which year its related to in the script, i.e. 2011 as year. In one of the other files the column year also exist. May this be the problem. If i not relate the data in the script the problems dissapear, but this couses other problems.

       

      Any suggestions??

       

      Anders

        • having problem with multipel rows in table

          Hi Anders,

          "For some reason, multiple rows are present in one of the straight tables" --> This is not quite correct. QV optimizes straight tables and shows only distinct rows. So if it seems for you having duplicate rows in one of your straight tables --> they are different! At least behind the scene, may be a leading or trailing blank or sth. like that.

           

          "In one of the other files the column year also exist. May this be the problem." --> Yes, .. .

          If I understood you right, you are linking different tables together via a field called year. So be sure to have in all source tables the same (and the very exactly same) format. For ex. excel stores dates and years as numbers and converts it to show the user a date. Maybe in one of your sources you have a timestamp formatted as year and so one.

           

          For checking the values and formats, I would load the corresponding year-fields in an extra app with fully qualified fieldnames and compare the values via listboxes and searchobjects. Let's see what's happening

           

          HtH

          Roland

            • having problem with multipel rows in table

              Thanks Roland,

               

              I will start searching. in the table first everything is showing correctly. for example all information for one area is showing correctly on several lines then the area information is repeated but only with the dimension year filled in the table. The other dimensions are blank on theese rows. so, the information is showed twice but the second time only with all years repeated.

               

              /Anders