2 Replies Latest reply: Dec 14, 2011 9:18 AM by Nicholas Weston RSS

    Cscript on 64-bit Server

      I'm having trouble running a macro  (.vbs file) in Qlikview Publisher via the supporting tasks. The macro sends an email and it runs fine logged into the console as Qlikadmin but when i run it in Publisher the Log file tells me that ;

       

      The specified executable is not a valid Win32 application.

       

      which after checking other posts indicates that the server is running on 64 and requires the 32bit cscript to run.

       

      As per HBerzajs' post in 2010, (http://community.qlik.com/thread/20886Batch vbscript for 64-bit server) I've tried amending the command line in supporting tasks to point to cscript (for 32 bit) before pointing to the .vbs file. Here's the code in the command line.

       

      C:\Windows\SysWow64\csript.exe C:\QLIKVIEW\EmailMacro.vbs

       

      When i run this i get

       

      "The system cannot find the file specified"

       

      I've checked that "C:\Windows\SysWow64\csript.exe" exists and it does. I've even tried putting a copy of cscript into C:\QLIKVIEW and running the command

       

      C:\QLIKVIEW\csript.exe C:\QLIKVIEW\EmailMacro.vbs

       

      Nothing happens though.

       

      We're running version 9.0.7773.9

       

      Thanks in advance.