1 Reply Latest reply: Jan 6, 2012 4:15 AM by Pierre Philouze RSS

    [QlikOcx] Class not registered exception

      Hi everybody !

       

      Last week, I tried to use the QlikOCX.ocx library in order to make some operation on QV documents from an external VB program.

      I installed Visual Studio express 2010 SP1 (VB) and added Qlikocx.ocx reference in my project.

      It worked fine but since the last week, I installed QV11. After that, it was impossible to open documents created with QV10. So I uninstalled QV11 and reinstall QV 10 but now in my visual studio project I got this error :

       

      Retrieving the COM class factory for component with CLSID {C3661E8B-415E-11D1-934D-0040333C91CC} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

       

      My code :

       

      Dim QlikApp As QlikView.Application

      QlikApp = New QlikView.Application <= line with exception

       

      I made a research in the registry and didn't find the C3661E8B-415E-11D1-934D-0040333C91CC value.

      I tried to register Ocx file with the regsvr32 but it didn't work and I didn't find solution on the Web. This problem make me crazy. Have you any idea ?

       

       

      Regards,